How to avoid BW for Windows to pop-up everytime the unlock timeout?

Hi, how to avoid BW for Windows to pop-up everytime the unlock timeout?
This is very annoying as BW for Windows disturbs you every time when you are focus on your work !
For example:
1/ you open BW for Windows and log on to your account. This help login to your work so you start working.
2/ As the timeout is set to 15mn for security reasons, after 15mn the BW for Windows stops being unlocked, but instead of doing this silently as it should, it is pushing BW for Windows application in front of the user !!!
Why? there is no reasons, the user does not need BW at all at that time (it is even the purpose of a timeout!)

How about if instead you set the Vault timeout to On system lock and the Vault timeout action to Lock ?
As the result Bitwarden once unlocked will be available to you all the time, but will not interrupt you. If you leave your computer - even just for a moment - you lock the system and unlock it again when you come back. Bitwarden will still be locked. So even if someone finds a way to unlock your computer that person will not be able to get into Bitwarden.

1 Like

Currently I have these settings:

I have currently set the timeout to 15 minutes (as I very often have to leave my computer and cannot always lock it, and having Windows automatically lock rapidly is annoying when I am reading).

Honestly, BW for Windows’s behavior of showing up in front of all applications when it has a timeout is none-sense. Who wants such behavior?

This problem is most likely related to this bug:

But because you have the “Ask for Windows Hello on app start” checked, it pops up the Window Hello dialog as well. Why? BW has this quirk in the implementation such that when it locks, it restarts the process to clear the plaintext memory. So when it locks, it is like an “app start” and pops up the dialog.

This quirk in implementation is most likely because of how electron manages its memory, and BW restarts the process for safety reason / implementation limitation. This seems fundamental and may not go away soon.

The following are some suggestions to try so you can live with the bug. Maybe you can check the “Ask for Windows Hello on app start” off, and see if you can tolerate the entire app coming to the foreground better. Perhaps also make the lock timeout sooner, so the behavior will happen sooner and less likely to interrupt you when you are deep in the middle of something.

1 Like

Thanks for the clear explanation. This is the same issue I have. I am going to test with Ask for Windows Hello disabled.

1 Like