How to autofill in Opera on Windows 10

URL does not autofill or be recognized. is autofilled. I have two password rules, one for each site. I am using Windows with Opera browser and the bitwarden extenstion. I am finding many other sites that do not autofill. It would first appear that websites that have a popup login window do not work?
Any ideas?

Is this even the bitwarden prompt with multiple accounts? The userids listed are not the ones I set up in BW. I have disabled opera password autofill and have no other pw managers.

Try making a Linked Custom Field with the name email, and linking it to your Username (which is where your email address should be stored).

I’ve described the step-by-step procedure for setting this up in an earlier post, which you can read here (you can ignore the information about TOTP in that post — just follow the numbered instructions below the posted screenshot).

Thanks, I tried that, but no change. In fact, i am questioning whether the nytimes login is even bitwarden, as the account password manager prompt does not match the emails i have set up in bitwarden. I have disabled the opera password autofill. Any other ideas?

I can confirm the popup window with accounts is coming from opera password - that little window is the action when you have disabled password autofill.

Change the URI Match Detection from Exact to Host. Alternatively, keep the match detection as Exact, but edit the URI value to look exactly like this:


This looks like you may still have another password manager enabled, unless you have additional login items for stored in your vault. When you’re on the login screen, is there a number shown in the badge counter for the browser extension, and if so, what is the number?

I have only 4 entries at the moment in the vault as I test out BW.
I don’t see the badge counter, and no website is using BW at all. Something with Opera? Something that needs to be enabled? I checked the extensions is enabled. I also disabled all other extensions to see if there was an interaction. Didn’t help.

Couldn’t you also just add a second uri: I did this when it wasn’t being identified in a different login area and it worked well.

Looks like BW does not work with Opera. Look at the comments in the extension and there are numerous reports that it has stopped working as of late last year. No go for me, then.

Opera is supported. I see no major bug reports for Opera on Github, and no major issues reported here in the community forum.

The one vault item in your screenshot was misconfigured. It is likely that your other 4 test items are not properly configured either. If you want assistance, let us know.

Thanks, I would like to get it working. What is mis-configured? They were .csv imported from opera password manager (a limited set of 4 for testing.)
Regarding a previous reply, I tried changing match to host, and also changing the URI to neither made a difference.
It appears BW is not running at all in the browser.

First of all, you have some password manager running that is not Bitwarden. This pop-up is not from Bitwarden:


You need to figure out what software is creating that prompt, and disable it (as it will interfere with Bitwarden).

Second, the screenshot that you showed in your first post appears to be from the Web Vault. The Web Vault is rarely used after you’ve done your initial import. Instead, you need to download and install the browser extension for Opera, if you haven’t already done so. You should see the Bitwarden icon ( shield :shield:, but with blue and white colors) in the sidebar.

Third, click the icon to open the browser extension (and log in if necessary), then go to Settings (using the “Settings” icon at the bottom of the browser extension window), then scroll down and click on Options>. Scroll down to the “Display” section, and ensure that the option Show badge counter has a checkmark.

After you’ve done all that, please report back, and I can take a look at your vault items.

ok, now I’m getting somewhere :slight_smile: I did not notice the Bw icon on the left side - I have signed in now.
I have already disabled opera autofill, the window popup for userids must be a feature when autofill has been disabled. However, BW still will not autofill any websites.
However, the badge counter does show the number of open tabs at a particular site - it just will not autofill…
Do i have to click on the DW sidebar and select an account and click on autofil each time i logon to a website? Seems clunky?

Follow the instructions here;

You have to disable both the Offer to save passwords option and the Auto Sign-in option, then export all your stored passwords, and finally delete all the passwords that are stored in your browser.


This isn’t correct. The Bitwarden badge counter shows the number of login items stored in your vault that match the currently open browser tab (this corresponds to the number of login accounts that you will be able to auto-fill into the currently open browser tab). If you typically only have one login account in each site, then the badge counter should either be 1 or not shown (of there are no matching logins for the open web page).

Can you now please navigate your browser to and check what the badge counter says? If it is a number greater than 1, then please click on the Bitwarden icon to open the extension, and take a screenshot (redact any personal information before posting here).

If the badge counter says 1, then open the login form, and click on the Bitwarden icon to open the extension, followed by clicking on the item that is shown at the top of the browser extension window. This should auto-fill the login form, which you can then submit. If this works, you can log out and try a more efficient method for auto-filling (will not explain those yet until we have verified that it works by clicking the item in the extension window).

Ok, seems to be working. Thanks for the clarifications.
I had disabled both pw autofill and offer to save.
Does BW always require the sidebar icon to be clicked and username selected? i.e. it cannot autofill the moment a web page login is loaded? (especially if there is only 1 username associated) or prompt you directly from the web page login?

No, there are faster methods, but I didn’t want to dive into those until you got something working.

The best method is to use the keyboard shortcut Ctrl+Shift+L to auto-fill. If you happen to have more than one account stored for the same website (i.e., if your badge counter is greater than 1), then you can hit Ctrl+Shift+L repeatedly to cycle through the available login credentials for the site.

Alternatively, if you go to Settings > Options in the browser extension, you can enable the option Auto-fill on page load, which will automatically fill in the form as soon as you go open the login page.

Thanks I have turned on autofill, and it’s now working as expected. Thanks for your help!

Arg, autofill has stopped working for any websites that I have multiple accounts for. Badge# shows the correct number of accounts, but autofill does nothing. Clicking in the userid box also does nothing. Clicking from the sidebar, then selecting an account manually does work as does cntl-shift-l.
Any ideas?

Well, Ctrl+Shift+L is auto-fill, so if that works, then it seems that what is not working is just the Auto-fill on page load. Have you double-checked the setting of that option under Settings > Options?

As shown in the screenshot below, there are actually three relevant settings that must be set properly:

  1. Under Settings > Options, the checkbox next to the global “Auto-fill on page load” option must be checked.

  2. Under Settings > Options, the dropdown menu below “Default autofill setting for login items” should be set to “Auto-fill on page load” (unless you want something different).

  3. When you open the specific login item for editing, there is an setting just below the URI field, labelled “Auto-fill on page load (if enabled in settings)”. In the associated drop-down menu, make sure that you have selected “Auto-fill on page load” (or “Use default setting”, if the default specified in Step 2 above is set to “Auto-fill on page load”).



I’m guessing that one or more of the three settings described above were misconfigured.

Hi, The general settings were both set to autofill on page load. The login item autofill settings was ‘use default’ which should autofill anyways (as it does for websites for where i have only 1 entry in BW.)
I changed it anyways to autofill page load, and there is no change in behaviour for autofil. However Badge# shows correct number of entries and cntl-shift-enter works.
Thanks for the help!

Not sure what could be going on then. Did automatic auto-fill (on page load) ever work for that site? Would you mind posting the URL of the site?

Nytimes: The New York Times
It was working a couple days ago (and continues to work for some sites with 1 account, but not all).