Firefox add-on 2FA only after repeated password

I have 2FA enabled. When logging into the Firefox Bitwarden add-on I get:

  1. Prompt to login (user name + password), without any option to pop-out the add-on (only have that pop-out option when already being logged in) or select something 2FA related.
  2. Only after providing the password I get a message that 2FA needs to pop-out the add-on in an extra window.
  3. In that new extra window I again have to type the password, and only then I get to use 2FA to finally log in.

Is there a way to prevent the 2*times password input in the Firefox add-on? Or pop-out the add-on at the 1st step?
Can that e.g. be related to a Firefox setting preventing pop-up windows …? (any hint where to check?)
Or is that intended (required concerning security) for some reason?

Note:
In the web interface it’s directly asking for 2FA after 1*time password input.
I’m using Firefox 82.0.2 with the latest Bitwarden add-on.
2FA = Yubikey in this case
‘pop-out’ refers to open in new window

There’s not an automatic ‘pop out’ option, but if you open the extension and notice you need to log in again, you can manually pop the window out using the button in the top left of the extension, and then you should be good to go for login/2fa with typing your password once :slight_smile:

@tgreer Thanks for looking into this issue.

Attached are some screenshots of the login process.
I think with the ‘button in the top left’ you refer to the one highlighted red in the last screenshot.
But that’s only available to me when I’m already logged in (already had to type my password 2 times), not during the login process.

But if I’m missing something please let me know.

  1. Start (also in the gear top left I don’t find a pop-out option)
    LoginPrompt0

  2. The initial login page where I have to type my my password the 1st time, otherwise there is no progress
    LoginPrompt1

  3. The information that U2F needs the pop-out window, after clicking ‘yes’ I have to type my password again, then I get the U2F interaction and proceed to 4)

  4. Finally after 2* typing my password I get the pop-out option (top left, marked red)
    LoginPrompt3

Let me give a workaround just in case someone else needs it.

You can log in at the sidebar on Firefox to avoid typing the master password twice.

2021-02-24 13_58_55-Window

1 Like

Yes, this works, but it’s not clear why it should be necessary to open a sidebar that you, otherwise, don’t want.

I was having the same issue!
Good to find the work around but I agree that the option to popout at login on the firefox extension would be nice to avoid having to go to the sidebar.