[Fatal] GPU Process isn't usable - SOLVED

PC: Macbook Pro Retina 2014 (Intel)
OS: MacOS High Sierra (10.13.6)

Brand new OS install. I can’t move up to Catalina or Big Sur because my primary use for this laptop involves the 32-bit legacy Java runtime and does not (and will not) have a 64-bit update.

Installed Bitwarden from App Store. On launch, about 5 seconds in, Bitwarden on Mac crashes. Launching from Terminal reveals these messages:

$ /Applications/Bitwarden.app/Contents/MacOS/Bitwarden
(node:598) DeprecationWarning: file property is deprecated and will be removed in v5.
(node:598) electron: The default of contextIsolation is deprecated and will be changing from false to true in a future release of Electron.  See https://github.com/electron/electron/issues/23506 for more information
[598:0622/185526.545978:FATAL:gpu_data_manager_impl_private.cc(445)] GPU process isn't usable. Goodbye.
Trace/BPT trap: 5

I think the part about Electron isn’t the actual worry. Googling that phrase seems like it’s a known thing and shouldn’t be causing the crash.

The only other place I saw the message about the GPU Process is from IntelliJ. I’m assuming there’s a runtime check of the environment and getting a value it doesn’t understand. There’s certainly nothing wrong with the hardware that I’m aware of. There isn’t anything I’ve seen on this error relating to Bitwarden.

At this point, the only thing I’ve installed other than security updates is the legacy Java runtime. Is the Bitwarden native client for MacOS written in Java? I’d be amused/confused if it were.

Any ideas on a solution or even pointing me in a direction I can solve this? Thanks

Trying to solve my own problem. The C++ source is here.

GpuDataManagerImplPrivate::InitializeGpuModes() calls FallBackToNextGpuMode() which throws the exception.

That message appears to happen when it can’t figure out its runtime environment. This message is from a Chromium library. I don’t have any Chrome-based browsers installed. Surely this isn’t a corner case as I can’t be the only person setting up Bitwarden before installing Chrome (I actually don’t use Chrome at all).

I think its better to file an issue on github - Bitwarden · GitHub

1 Like

@vachan I’m happy to do that. Some projects like having issues vetted through the community before it gets to Github. Some projects get really annoyed when randos post issues to their trackers. I don’t know the lay of the land with Bitwarden yet, so I thought posting here was the least friction.


I’m pretty much stuck in Mojave as you for the same reason (support for a legacy 32bit platform). That said, I don’t have issues with Electron apps (Bitwarden being one of them).

Most of the shortcomings in Bitwarden are because of the limiting factors that imposes the Electron architecture, unfortunately there’s no official alternative for clients (that I know of). Hopefully one day a brave hero writes something in a C derivative language, meanwhile you’re out of luck.

Now, I have different Mac configurations (personal, family and work) and none of them have ever suffered that issue. I’ve seen in the past GPU issues not related to Electron but to Hackintosh. If you’re running it, that is most likely the issue.

In any way, tray the good 'ol SMC/NVRAM/PRAM reset, every now and then works like the PC restart.

1 Like


Zapping NVRAM didn’t help, so I updated somewhat hesitantly, to Mojave. After reinstalling the legacy Java runtime and confirmed that my primary apps still work, I tested Bitwarden. It allowed me to log in and retrieve my vault. It’s not exactly a solution, but it worked for me. I’ll call this one SOLVED.

Thanks for your suggestions.

1 Like

Its great you got it running, just a bit of advise: don’t go above Mojave if you have 32bit legacy stuff.