Execute Bitwarden .appimage ubuntu program from USB stick?


i,m using ubuntu 20.04 LTS but i wonder why i can,t execute the .appimage from a USB stick. If i use it on the device i have no problems. I don,t want to use any USB live system, i just want to execute linux programs from a USB stick. Do i have the chance to give the USB stick sudo permissions temporally. Where are the geeks that can assist ?

Place AppImage on Desktop of Ubuntu

open a terminal and type this:

cd Desktop && ./“filename”.AppImage

If it doesn’t run the terminal will tell you WHY!

You can also try and invoke sudo as well, but likely that will make NO difference. I don’t advise running in sudo.

I have had many issues with AppImage when I am not running “bare metal”. I have had to correct things while running AppImage on VM’s, when they run perfectly on the same operating system only running bare metal. If you get errors on the terminal and need further help simply copy and paste the terminal output here and someone can jump on.

Make sure to change permissions to make AppImage executable. It may also be worth looking into setting up portable mode if you want to contain app data/config on USB: Using portable mode — AppImage documentation

Maybe something like following on Terminal:

$ cd /<usb-path>
$ wget https://github.com/bitwarden/desktop/releases/download/v1.25.1/Bitwarden-1.25.1-x86_64.AppImage
$ chmod a+x Bitwarden-1.25.1-x86_64.AppImage
$ mkdir Bitwarden-1.25.1-x86_64.AppImage.home
$ ./Bitwarden-1.25.1-x86_64.AppImage

You will need to find your <usb-path> based on how you mounted USB.

when i reach the step $ “./Bitwarden-1.25.1-x86_64.AppImage” i get an error message “no permission” . In GUI mode i can,t change the permissions to execute either. When i make the step “chmod a+x Bitwarden-1.25.1-x86_64.AppImage” i don,t get an error message. I did not try the sudo command neither. Permission on the file on the USB stick is : 644, where it don,t works, but on the computer is 700.

Looks like issues with adding “execute” permissions to USB file system.

Just to check, what is the format of USB?
I think Windows formats like NTFS/FAT32 don’t accept Linux permissions.
It may be possible with Linux formats like EXT4.

EDIT: If USB is currently using Windows format and you only plan to use USB on Linux, it may be better to reformat using Ubuntu’s Disk Utility.

If you want to keep using USB on Windows, then you shouldn’t reformat since Windows cannot read EXT4 format. In which case, you need to change mount permissions as discussed below.

Alternatively, you can try (re-)mounting drive with execute permissions.
I don’t know if there is option in GUI mode.

There should be a Terminal command to remount.
Not too sure exact option, but maybe something like
sudo mount /<usb-mount-path> -o remount,exec