Error on updating: Value cannot be null. (Parameter 'logger')

I just wanted to update my self hosted bw instance.

This instance is running in a dedicated debian vm on proxmox.

So i ran the following:

/opt/bitwarden/ updateself
/opt/bitwarden/ update

Everything looked good until I received the following error at the end:

Unhandled exception. System.ArgumentNullException: Value cannot be null. (Parameter 'logger')
   at System.ThrowHelper.Throw(String paramName)
   at Microsoft.Extensions.Logging.LoggerExtensions.Log(ILogger logger, LogLevel logLevel, EventId eventId, Exception exception, String message, Object[] args)
   at Microsoft.Extensions.Logging.LoggerExtensions.LogInformation(ILogger logger, String message, Object[] args)
   at Bit.Migrator.DbMigrator.MigrateMsSqlDatabaseWithRetries(Boolean enableLogging, Boolean repeatable, String folderName, CancellationToken cancellationToken) in /home/runner/work/server/server/util/Migrator/DbMigrator.cs:line 46
   at Bit.Setup.Program.MigrateDatabase(Int32 attempt) in /home/runner/work/server/server/util/Setup/Program.cs:line 194
   at Bit.Setup.Program.Update() in /home/runner/work/server/server/util/Setup/Program.cs:line 158
   at Bit.Setup.Program.Main(String[] args) in /home/runner/work/server/server/util/Setup/Program.cs:line 56

I am not sure what the issue is. All containers are up and healthy after the update.
I can still login to the web vault without issues. Also syncing works.

I only noticed that the web vault was a bit slow when trying to login.

Not sure what exactly went wrong when updating and what the consequence is. So far everything seems fine.


Same thing for me as well. I’ve been self hosting bitwarden for years, I think since 2018 and this is the first time I encountered an upgrade error. I did rerun updatedb command and that worked ok, but a little concerned something may have failed during the upgrade from 2024.2.0 > 2024.2.2

1 Like

I’m on Synology.

Same error here, but everything seems to working for now. All containers are running.

Same error here …
I run the .sh with sudo despite warnings… You use bitwarden user ?

Same here on self hosted Windows Server. Seems to work as far as I can tell, login via MFA and the vault is there, but not comfortable running in an enterprise like this. Will go back to previous snapshot and contact the BW support.

I got this answer from the Bitwarden support team:
The error error message during the upgrade is something we’ve seen, but seems to be transient, so it shouldn’t actually be affecting anything.
This is something that we are looking into and we will follow up with you as soon as we have more information!
I will post again if I get any more information.

1 Like

Based on this answer from the support team today I will proceed to update our environment tomorrow:

I’ve discussed this with our integration team and this was the outcome

This is transient ; it’s related to logging within the setup container while it’s doing database migrations - even if that process fails entirely, the admin container starts next and will apply any missing migrations.

But to be extra ​please make sure to back up your data or create a snapshot you can recover from.

1 Like

Happened again for me upgrading to 2023.3 release.


The exact same thing happend to me when upgrading to version 2024.3.0 from 2024.2.3 (self-hosted instance on Ubuntu 22.04 VM). Everything seems to work normally except e-mail notifications (which were working before for sure). I am not receiving the confirmation email to log into the admin portal anymore.
I will try to find out why e-mails are not being sent. My SMTP server has not changed and the Bitwarden config file is unchanged, so at the moment I can not explain the reason why e-mails are not being sent.

An additional note: SMTP E-mail sending stopped working with my custom smtp server which was working without issues for months when I updated bitwarden to version 2024.3.0 from 2024.2.3.

I have changed the configuration in the global.override.env file and am using gmail for smtp e-mail notifications, e-mail sending is working again. But I am unsure why my custom smtp server stopped working after performing the update to version 2024.3.0 from 2024.2.3.