Directory Sync (Active Directory) will sync groups but not users (Self Hosted)

When I run the directory sync, it will fetch the right users and groups. However when I Sync Nor or Start sync. Only the groups appear in the web vault. I can’t understand why the users won’t appear. I’ve tried clearing the cache and deleting the group from the web vault. But each time I try to re do the process it only syncs the group and no new users appear.

My current seats are 6, and there are 6 users I am trying to sync.
Enterprise License (Trialing)

Any ideas why this might be failing?

Edit: The master account is considered a seat. Upping my seats to 7 suddenly flooded the list via Sync now.

If you have more users in your AD then your license allows bwdc will fail silently and not install any new users. My solution to this was to create a bitwarden group in AD and just put the users/accounts in that group that need access. Then you can set up a user filter on the sync confg;

“userFilter”: “(&(memberOf=CN=bitwarden,OU=Groups,DC=work,DC=corp))”,