Desktop Failing Updating - Spinning Circle ONly

Tried updating and all I get is a spinning circle with popup to restart. Upon restart it starts again. Should I uninstall/reinstall w latest version? Will my data be safe and do I need to export my data prior to uninstalling, then import it back in?

Using Windows 10

Yes, uninstall, reboot (do NOT just shutdown and switch the computer back on, as this is different than rebooting) , reinstall (for all users).
Yes, your data will be safe as it is on the servers from Bitwarden. Therefore exporting is not necessary. However, exporting on a regular basis still is a good idea to have backups. But before you do that think about where to save it and how to protect it.
No, do not import your data again. This would only duplicate all your (already existing) items.

Edit: Typo.

Peter - thanks for that detailed and VERY quick response. Appreciate it!!

A quick second question. I use desktop to log into and switch three accounts (2 are other family members). Usually, when I start up in the morning all three are visible to choose from to log into. Today one is missing. not a big issue but odd it was arbitrarily missing. The other two (mine and family member) were there. Why would one just disappear? The only shared variable between the two that appeared is that they are both Premium accts., whereas the missing one is a free acct.

Sorry, I cannot help you on that.
@dh024, @danmullen: Any idea ?

Hmm, I’ve never come across that before.

This behaviour occurs in the desktop app if an account is logged out. If you did not logout yourself, there are at least two reasons I can think of for it to happen automatically:

  • you have your vault timeout settings set to logout rather than lock
  • if you are using 2FA, your 2FA trust may have expired, forcing a new login

I am not sure why Bitwarden doesn’t ‘remember’ the logins after logout, like the browser extensions do. I doubt it is a bug, but it is definitely inconsistent behaviour.

I will test it a bit this weekend. Willing to bet that I DID log out of that one account but not the other two, and that’s why it didn’t re-appear.

1 Like

This happens too often. 3 times for me. I just end up using web interface.

I see other posts in other sites regarding this. Seems like a lingering bug.

A full removal and reinstall may fix the issue, but is that really a solution to an obvious design flaw?

So my email shows in upper right. So I try to click add another account. Nothing happens. I close app and restart app and it asks me to set up account. Great. Now it works. Not a great fix, but quicker than deleting and reinstalling. But the bug is real.