Can't login to bitwarden using strong password

I tried to create a login for my web-based bitwarden login.

I added the username and password and verified that they’re correct.

But when auto-filling the password, bitwarden only fills part of the password so the login fails. Looking at the password in bitwarden, it looks like it’s on multiple lines so apparently only the first line is getting pasted.

But when I edit the login and view the password, the password is all one one line.


What’s the secret to get the entire password to paste?


What is the website that you are trying to log in to?

I have had to “prune” my passwords a few times due to website construction limitations. It seems that a few confirmed my user and password BUT then when I tried to login the handshake was a FAIL. Some major utilities even restrict to 10-15 character maximums where even though their system says you are good to go after attempting to login with e.g. 25 character password it will FAIL every time. Not sure there is anything that BW can do about such things out of their control.

?? — what kind of password length are you using on these failed logins?

As I mentioned above, this 100-character password was for the Bitwarden site itself. It refused to paste correctly from the bitwarden browser app. Only the first “line” of the password was pasted.

But when “editing” the password in BW, you would see the entire password on one line.

Random, 100 character password (This failed login was on the bitwarden site itself, my main login).

OK, thanks for clarifying that you were attempting to log in to

In your OP, you stated that the problem was with auto-fill. For testing purposes, would you mind clarifying exactly how you attempted to transfer the password from the browser extension into the login form? For example, did you copy the password by highlighting it and using Ctrl+C, or did you use the “Copy” button to the right of the password field? Did you use Ctrl+V or Ctrl+Shift-L to enter the password into the Web Vault login form?

I’d be inclined to add from what I think I read. You were logged out of bitwarden, then attempted to login using some sort of auto fill. But if your logged out of bitwarden that autofill that you attempted to use could not be bitwarden since it wasn’t logged in. Could it have been a saved password in another manager (google password , apple, etc)?

How is bitwarden auto filling a password for bitwarden when your attempting to login to it?

@Gerardv514 It is possible to be logged in to the browser extension, but logged out of the Web Vault. The login/lock status of each client app is independent, even on the same device.

Yup, ok that makes sense.

I was using the browser extension to try to log into the bitwarden site itself using the bitwarden’s site’s credentials.

Isn’t that exactly how it should work?

But, only part of the password got pasted. If I manually entered the password via copy and paste (outside the browser extension), then it worked.

Hence my question.


Yes that scenario would work.

To attempt to help you (or to see if a bug report will need to be filed), I would like to attempt to reproduce the behavior you are seeing. In order to be able to do this, I need your answer to the question I had asked above:

There are many different ways that a user could be “using the browser extension to try to log into the bitwarden site”. I need to know the exact method that you have been using when this problem occurs.

Not following the logic here. How could any human enter, from memory, a 100-chatacter password? That’s not an optional step, since you have to enter it, manually, in order to log into your vault.

Maybe it is a 9 or 10 word passphrase? Still difficult to memorize, but not impossible.

Well, I have tested every method I can think of, and none of them caused a 100-character master password to be truncated:

  • Autofill by opening browser extension and clicking login item card in Tab view.
  • Autofill by opening login item in browser extension and using “Auto-fill” button.
  • Autofill using Ctrl+Shift+L keyboard shortcut.
  • Autofill using right-click context menu Bitwarden > Auto-fill option.
  • Auto-fill on page load.
  • Copy password using :key: button on Tab view of browser extension.
  • Copy password using “double-square” copy button in password field of login item when the item is opened for viewing in the browser extension.
  • Copy password by opening item for viewing in browser extension, toggling the visibility (:eye:) button, then highlighting the password by clicking-and-dragging, and finally using the Ctrl+C shortcut to copy.
  • Copy password by opening item for editing in browser extension, toggling the visibility (:eye:) button, then highlighting the password by clicking-and-dragging, and finally using the Ctrl+C shortcut to copy.
  • Copy using right-click context menu Bitwarden > Copy password option.

For all of the five “copy” methods, I mostly pasted (into the password field on the Bitwarden login form) using the Ctrl+V keyboard shortcut, but I occasionally used the right-click context menu to select Paste as plain text. I believe there would be at least four different possible pasting methods (Ctrl+V shortcut, Ctrl+Shift+V shortcut, context menu Paste command, and context menu Paste as plain text command). I have not systematically tested all 20 combinations of these 4 pasting methods and the 5 copying methods outline above (nor do I intend to). There may be additional pasting methods using the browser’s main menu.

The bottom line is that despite my best efforts, the behavior described by OP cannot be reproduced on my system (Windows 10 20H2, Chrome 109.0.5414.120, and Bitwarden browser extension 2023.1.0).

Three questions for @computing:

  1. Which of the 5 auto-filling methods or 20 copy-paste methods described above are you using, or are you using a different method?

  2. What are the specs (version) of your OS, browser, and browser extension where you are encountering this problem?

  3. Are you sure that you ever set your vault master password to equal your random 100-character string? Can you log in to the web vault by copying and pasting the master password into Notepad (to verify that the full password has been copied onto the clipboard), and then immediately pasting the clipboard contents also into the master password field? Before clicking the Log in with master password, button, please toggle the visibility (:eye:) button to verify that the full password was successfully pasted into the password field. If you’re still having trouble pasting this way, then type the password manually into the password field.