Can't log into bitwarden, useless error message

The error is as described. Bitwarden wasn’t syncing on my iPhone 13 Pro Max, so I tried logging out - assuming maybe a session had expired or something. Now, it won’t let me log in. I’ve tried reinstalling the app several times, but no luck. Whenever I enter my password, I get “An Error has occurred.”, with no further explanation. I know for sure it’s not me entering my password wrong, as I logged into the desktop client to make sure just before posting.

Edit: It fixed itself randomly? A more useful error message probably would’ve helped.

1 Like

I haven’t been able to login for four days now. My password is correct . I have had network errors, the error you mention and also the wrong username or password is incorrect.

1 Like

For official support, please reach out to the support team.

I have already exposed it here the problem is the same I access via web in local and that message appears since I updated it must be a bug in the new version.

Hey @litris for official support (the team requires additional details to investigate) please submit a bug report with steps to reproduce here: Issues · bitwarden/clients · GitHub or contact the support team with additional details.

@litris: I’m the one that happened to reply to the GitHub issue. I don’t work for BW - I’m just a user like you. :slight_smile:

The screenshots you provided there and here are the web client stating there is a weird error with the server/backend. And it sounds like you’re unable to log-in regardless of whether you’re use the web client or iOS, correct?

And with what you shared it sounds like you upgraded one of the variations of the BW server deployed via Docker.

What Docker container do you have deployed?

I don’t understand your refusal to contact tech support.

If you want anybody from the Bitwarden user community to help you, you will at least need to provide some basic information, like the exact version of the server that you are running. Please follow the instructions in the link below, and post the screenshot:

That’s great to hear and I’m glad you found a resolution that works for you, but I’m still curious what you’re actually running / what you are (well, were) trying to update from and to version-wise. :slight_smile:

i.e. Which BW Docker container(s)? Which BW server builds/versions?

This error:
/opt/mssql/bin/sqlservr: Error: The secrets directory [/var/opt/mssql/secrets/] could not be created. File: LinuxDirectory.cpp:523 [Status: 0xC0000022 Access Denied errno = 0xD(13) Permission denied] stderr

You still didn’t answer the question about the server version that is shown in your Bitwarden System Administrator Portal.

Based on your reference to the site and the types problems you were having, I’m guessing that you’ve actually used an older version of Marius’s webpage from 2022 or earlier — not the current version of Marius’s instructions (which shows how to install the Beta release of Bitwarden Unified). Prior to 2023, the instructions on Marius’s website actually resulted in the installation of a Vaultwarden server — not a Bitwarden server. Vaultwarden is not a Bitwarden product and therefore not guaranteed to be compatible with Bitwarden’s client apps.

In case I’m mistaken about the timing of your install, and you actually did follow Marius’s most recent instructions for installing a beta release of Bitwarden server, then you will probably want to heed the Bitwarden’s disclaimer for the beta version:

:warning: Warning

This is a beta release, which means that this deployment option may be unstable and have issues. If you manage a Bitwarden organization vault, we recommend using the officially-supported, standard deployment option.


Either way, you are not using officially-supported server software, which is the root cause of the problems you have been experiencing.


I used the bitwarden script original 2023.3.0


It is already solved, it was not because of the permissions.

It is that the new install does not create those folders in two locations I have created them manually and it is already working!

I don’t update anymore!

It doesn’t let me create a new post and I put it here, little help from the service I did it by intuition, they created a defective installer, perhaps to go from the old versions to the newest ones.

I leave below what I had commented before about the solution, how the installation file gives an error, in case it happens to someone.

Had same issue, found a suggestion to disable wifi and use cellular connection. This seems to have worked but I has also deleted and re-installed the app.

Have just given up on this software.
I have deleted the original account and created a new one, AGAIN
I go to login via the browser and still get the same error message as you have got yet again.
I just can’t be bothered to try anymore, if they can’t be bothered to create software that works then
that is their problem.
Fed up with it as it seems you have to use the web login in order to import ones passwords.
Why you are unable to do this through the app gods knows.