Can't get extention to auto-fill to work an Firefox (desktop)

As the title says, I can’t get the Bitwarden Firefox extension to auto-fill login forms on any website when I use Firefox. I was previously using Brave and it works there, but I’ve switched back to Firefox and it doesn’t work. I’ve searched the settings in both the extension and Firefox and don’t see anything that helps there.

I did get it working when enabling the experimental “auto-fill when the page loads” setting but I can’t use that because we have many accounts for certain websites and it automatically fills the wrong accounts.

Edit: Upon further use, it seems the context menu options are completely broken in the Firefox extension. I cannot copy/paste a username or password from the context menu either.

Could you specify what methods have you tried to activate autofill on Firefox that have not worked?

For example, have you tried the keyboard shortcut?

  1. On Windows: Ctrl + Shift + L.
  2. On macOS: Cmd + Shift + L.
  3. On Linux: Ctrl + Shift + L.
  4. Safari: Cmd + \ or Cmd + 8 or Cmd + Shift + P.

I am trying to log in via the right-click context menu ->Auto-fill->[Account Info]
Ctrl + Shift + L does nothing.

I also tried disabling all other extensions to see if that helped, but it didnt.

Upon further use, it seems the context menu options are completely broken in the Firefox extension. I cannot copy/paste a username or password from the context menu either. (Copies nothing.)

Edit: I have done some more testing and it seems to work 1 out of 5 times on average, maybe less. I can get it to populate the field if I click the account info over and over.

I use Firefox as well. I have the Auto-Fill checked in the settings menu, but maybe 30 or 40% of the time it does not fill the field when the page loads. This happens to me every day on Gmail as I check my email maybe 10 times a day. I can use the context menu to fill the field though so not the same issue as OP. What I do in that case is, I reload the page and it populates the field every time.

I notice that BW is a hog on resources and loads very slow when you click the browser icon to open the tabs view. If I had to guess, I would say that BW is not recognizing the page field when the page first loads, but if you load the page again, it does.

I have noticed that if I open several tabs at once, that BW seems to be waiting for me to activate the tab before it fills the fields. When I click on a tab for gmail say, BW then (usually) does the animated ********-> to populate the field. Perhaps the BW addon code should fill fields even if the tab is not active at the time of loading. Also, get rid of the animated filling of the field. Your code team needs to cut down the bloat, BW clearly has a feature bloat issue. I’ve only been using it for a week and I already want to go back to LastPass.

Same problem here with Firefox 86.0.

Moving from Lastpass, I find a number of features either missing or broken in Bitwarden.

  • When I revisit a registered site, Lastpass can be configured to automatically enter my credentials and log me in without any action on my part. With Bitwarden, I must tell it to send the credentials.
  • Lastpass detects when I create a new account and offers to save my credentials. With Bitwarden, I must manually add the new account.
  • Sometimes Bitwarden will fail to enter credentials, not even copy-and-paste works, forcing me to manually type my username and password.

Are the above expected behaviors, known bugs or something else?

@markmedici I think those are a mixture of bugs and features.
There’s a setting in “Options” of the browser plugin for “Enable Auto-fill On Page Load” - I think it’s turned off by default.

I do get prompted to save new account credentials by Bitwarden. Maybe that’s a setting too?

RE: The OP issue where context menu didn’t work - I’m not sure if there was an update or something, but my context menu option is working consistently now. Have no idea why lol. Also, I have discovered the CTRL-SHIFT-L works fine now and is more convenient than the right-click context menu anyway.

There was a firefox update since I posted this, perhaps that fixed it. So if you’re having this issue, make sure your Firefox is updated - That might fix it. :man_shrugging:

1 Like

I’ll give it a try and report back. Thx

It seems to be working reliably now. At least when Bitwarden isn’t locked due to inactivity. After entering my PIN I have to either click to fill or refresh the page to autofill. I guess that’s a reasonable situation, because otherwise Bitwarden would have to rescan every window and tab looking for a password field.

I just loaded it on my Android smartphone today, so I need to see how it does there.