Can't get Bitwarden to unlock using Touch ID or PIN

Hi everyone, i’m trying to setup Bitwarden to authenticate using Touch ID or a PIN on Mac, but all of the settings I enable always make the app demand the master password each time I open it.

The only way I can get around this is setting the vault timeout to “never”, which I don’t think is safe. I just want to be able to use Touch ID instead.

Any tips ?

Hi John (@jsn182) - welcome!

Before we start troubleshooting your issue, have you followed the directions in these two help articles? They should provide you with all the information you require:

If you have, can you please give us more details about what Bitwarden app or client you are using as well as the type of device and OS you are running it on? Thanks.

Thanks for the reply ! It’s the BW app, on Mac. No matter what settings I select, I am always prompted to enter the master password unless I set the Vault Timeout to “Never” - but that’s risky. Is there any way I can enable touchID each time I open the app instead?

Is it the desktop app then? If so, anytime you close the app completely, you will always be logged out for security reasons.

What you can try doing is change your app options to close to the menu bar instead of closing completely so that the app stays resident in memory and does not log you out.

Let us know how you make out!

I’m coming from 1Password, the desktop app had a simple feature that allowed you to use TouchID to open it. The point of a good master password is a long string that isn’t easy type, why would BW require this every time it’s opened ?

I don’t think never closing the app is a solution. Then it’s still open, and the security risk is still there.

Hi John - sorry, I may have mis-spoke in my previous post. My apologies. Can you try the following settings in the Bitwarden Desktop App Settings:

  • Vault Timeout: 30 minutes (or whatever option works best for you)

  • Vault Timeout Action: Lock

  • Unlock with Touch ID: Enabled

  • Unlock with PIN: Enabled (optional)

If you use those settings, you should be able to open your vault with Touch ID unless you exceed your vault timeout criterion. Let me know if this works for you. Cheers!

Hi David, thanks for replying. My point was, no matter what the settings I enabled (30 min, idle, etc.) and selecting “Unlock with Touch ID” - the app still requires the master password everytime it’s closed and opened.

Even the settings I suggested? Let me know if those work.

Oh, also make sure that in the Unlock with PIN setting you disable the option to unlock with master password on restart.

Yes, with those settings TouchID is never triggered and the master password is required. Keep in mind I am closing and opening BW because leaving it open and running is a security risk if my machine is ever stolen.

Well John, I am not sure what to tell you now. I just tried those settings on two macs (one running Mojave, one on Montery - both with Bitwarden Desktop 1.32.0), and it works for me.

I can completely shut down the Bitwarden Desktop app, then reopen it without having to enter my master password - only my PIN.

Why this doesn’t work for you has me stumped. So sorry!

It’s ok thank you for your responses, i’ll continue to troubleshoot.

Hi! I had the same problem using in both the Chrome and Firefox browsers.

First, some background. My PIN was working when I only used the BITWARDEN browser extension. But I visited the BITWARDEN website (https://bitwarden.com/), signed in, and visited my account options. Thereafter, I could not use my PIN on either the website or the extension.
The fix was to do a logout of my account from the extension. Then I logged back in. This reset all my options to the defaults. After I reset the PIN option it worked as advertised. So now I will only use the extension and will not revisit the website so as to avoid recreating the problem.

Hope this helps.