Cannot login in plugin or desktop application but the web GUI works

Hello, I have some troubles setting up a personal BitWarden. After docker install I can login to web application, but not in the plugin or desktop app (password is 100% right as it was copy-pasted).

Does anyone have any idea why would I get errors about wrong username/pass when logging in? Or where to get some logs?


The BitWarden itself is behind my reverse proxy on apache2 (different machine than bitwarden), this is the config:

<VirtualHost *:443>

  ServerName warden.$MYDOMAIN
  ServerAdmin [email protected]

  ErrorLog ${APACHE_LOG_DIR}/bolt-error.log
  CustomLog ${APACHE_LOG_DIR}/bolt-access.log combined

  SSLEngine on
  SSLCertificateFile /root/cert/$MYDOMAIN/fullchain.pem
  SSLCertificateKeyFile /root/cert/$MYDOMAIN/privkey.pem

  ProxyPreserveHost On
  ProxyPass / http://192.168.XXX.YYY/
  ProxyPassReverse / http://192.168.XXX.YYY/

# I got this from womewhere else, but it seems to be working (no more ws errors i nbrowser console)
# Without this web GUI still opens
RewriteEngine On
RewriteCond %{REQUEST_URI} /api/v[0-9]+/(users/)?websocket [NC,OR]
RewriteCond %{HTTP:UPGRADE} ^WebSocket$ [NC,OR]
RewriteCond %{HTTP:CONNECTION} ^Upgrade$ [NC]
RewriteRule .* ws://192.168.XXX.YYY%{REQUEST_URI} [P,QSA,L]


I have solved the problem… I did not select custom BitWarden URL in plugin/desktop app.

Now it works.