Cannot export vault to Firefox

I don’t give up easily but exporting and syncing in Bitwarden has me stumped! I have been trying all the web suggestions on how to do this but nothing has worked for me. I started using BW in Firefox but after a few weeks I moved to Opera (for other reasons) and found that BW is not as well integrated as it is in Firefox. After a couple of months in which I fully populated BW Opera I now want to move back to Firefox but all exporting my .csv files achieved was to duplicate all the entries in BW Web. Is there anyone out there who has had sucess exporting to Firefox or Syncing with BW Web ? Any ideas how I can get this to work. Doing it manually will be a chore - 36 entries !

Why do you want to export / import your data? There is no Bitwarden “Opera” or Bitwarden “Firefox”. Instead you have “your” Bitwarden account with the accumulated data of everything you put in there. All that data is stored online. It is encrypted in a way that only the right combination of your eMail address and your master password can decrypt it, so that only you can see and change anything.

1 Like

To add to what Peter_H has said, if it has been setup properly the Firefox and Opera clients will already be synchronised. They will also be synchronised with the Web Vault. Setting it up properly means using the same email and master password to access your vault (which is stored in the cloud (unless you are running it on your own server)).

In this situation I would either edit things in the Web version, which allows you to select multiple items and delete them, or clear the vault and import my latest version from Opera.

1 Like

Thanks for the responses!
I use the same username and key password on all three locations - Opera, Web and Firefox. I understand that there is only one version of BW, I only used Opera and Firefox to differentiate between the different implementations Syncing works between BW in Opera and the Web but repeated attempts to sync BW in Firefox with Web just does not work. I am thinking that I should uninstall BW Firefox and do a fresh install or is there a simpler solution?

Reinstall would be best since you don’t actually lose anything when you reinstall except for a few settings.

Yes, it was the solution! Thanks to all who replied,


Installed BW extension to Chrome and to Firefox on same Windows 10 system. Logged into both extensions as same BW user with same password.

Using BW extension in Chrome on another laptop (Linux) and a Linux desktop. Using the Android native app on my phone.

Sync to vault works fine on all of the above except Firefox, where as far as I can see I’m logged in, but nothing at all shows up in the vault.

On Firefox extension, Settings → sync → sync vault now shows “Syncing complete” popup but vault remains empty. Verified by clicking “My Vault” at bottom of extension popup and observing “There are no items to list” on main panel, unlike extension on other browsers which shows “Types 4”, “Login”, “Card”, and so on as expected.

Settings → log out → accept confirm popup causes log in screen to appear. Logging in appears to succeed however “There are no items to list” screen appears. I’ve tried this about 40 times, I am reasonably confident I typed the login information correctly at least a few of these times.

Uninstalling and reinstalling extension does not help the situation.

Timestamp on laptop is correct. Plus, as noted, Bitwarden works fine on Chrome on same laptop.

Not using any VPN or ad blocker.

Firefox is 91.0.2 64-bit, up to date.

Problem has existed for at least a year.

I can get to Bitwarden vault via web page from same browser.

Should I simply conclude bitwarden does not work with current firefox on Windows? Have not tried it with Firefox on Linux, as Firefox is not installed on any of my Linux boxes.

1 Like

That is very strange behaviour, Dan - I have been using BW on Firefox for a few years with no issues whatsoever. Currently, I have BW for FF installed on three Windows PCs, three Macs, and two Linux boxes.

You might try reaching out to the Bitwarden CS team to see if they can help:

I’ll be sure to keep an eye on this thread. Looking for the same information. Thanks for sharing. Bumped into your thread.

Yes, I am having the exact same issue. Works fine everywhere except firefox on my laptop.

I think the local data file it uses for the vault must be corrupt. If I knew where it was, I would delete it and let BW recreate a fresh one to sync to. Would be cool if someone from this forum would tell us where the data is stored.

The solution might be that firefox reset thing that it has (I can’t remember the name) but it obliterates your firefox user data and starts again. Annoying if you want to keep history and cookies etc. So I’m not gonna follow that route just now. Hoping someone can point out the data file…

I would try removing the extension from Firefox, then shutting it down, restart Firefox and reinstall the extension. That should have the same effect. :crossed_fingers:

You might be on to something. Unfortunately the problem is likely in one of the database files in your firefox profile.

Not having the time, patience or inclination to delve into those, on a computer where I don’t use firefox much but where I was easily able to repro the problem on a fairly old profile, I tried the brute-force solution of removing the entire .mozilla directory then starting Firefox. After reinstalling Bitwarden extension, it worked fine.

In my previous post, referring to tezza197 post.

In reference to dh024 post, I’ll try removing the extension, shutting down firefox, restarting firefox and reinstalling the extension, on the computer where I actually use firefox, and post the results here. Thanks all!

Success! On the Windows computer where I use Firefox, the sequence

Remove Bitwarden extension
Restart Firefox
Install Bitwarden extension
Log in to Bitwarden on the extension window


Should note yesterday’s test on a Linux computer yielded similar results: I had previously installed Bitwarden on Firefox, a browser I seldom use on the computer, and reproduced the error seen before on Windows/Firefox. Shutting down Firefox, completely removing the firefox profile directory (.mozilla/) then restarting firefox, installing the extension and logging in, fixed the problem, at the expense of removing all saved bookmarks, extensions, configurations etc. Glad to see the less drastic solution worked on Windows. I believe it would have worked on Linux had I tried it there first.

Yeah I just tried that and it fixed my issue too. Very happy about that. Thanks for the suggestion. Hope this thread helps others.

upon the firefox restart, I noticed that it updated itself. Perhaps previously my FF had fallen well out of date because I hadn’t bothered to exit that instance in a long time (which tends to be the usage pattern on my laptop). Something about the sync protocol had changed which required a newer version of FF or the extension? I dunno. Perhaps that had something to do with it.