BW Passkey Prompt Anomaly?

I had a passkey set up in BW for my GitHub account. This worked well, with the BW Chrome extension correctly offering the passkey to complete the login process.

Today I decided to try adding a second passkey, utilising Windows Hello (Facial Recognition). Again, this worked well but now I was unable to use my original BW saved passkey.

So I decided to delete the Windows Hello passkey from my GitHub account, both on GitHub and from Windows settings → Account -->> Passkey Settings.

I expected that this would result in Bitwarden detecting and offering me to confirm the passkey. But it didn’t. Instead, I get this:

image

When I press Cancel, I get dropped back to the GitHub login screen which now says Authentication Failed.

I can still log into GitHub using username/password plus 2FA code but that’s not the point.

Out of curiosity, I tried using MS Edge which also has the BW extension set up. In Edge, I can still log into GitHub using a passkey, offered by the BW extension.

So it seems, the Chrome extension, for some reason is not responding/recognising that there’s a passkey set up.

Am I missing something? Any suggestions how I can fix this?

Many thanks.

I realise I’m replying to myself here (lol) but I thought I’d give an update as I’ve worked out the solution.

What I did was I went into Settings (in the Chrome extension) and Excluded Domains. In there I found that somehow, github.com was added in. I simply deleted this entry and refreshed the GitHub login page. Now when I selected Sign in With A Passkey, BW responded by prompting for confirmation of the stored passkey. Voila! Login worked perfectly.

1 Like