Bw-mssql container keep starting

Hi all,
i am a noob on bitwarden and this is my first installation (on primes)
BW is istalled on a VM, 2x CPU, 4GB RAM, 20GB HD.
SYS-SO: Ubuntu 20.04.4 LTS …
First I installed the latest docker-ce and docker-compose
and than I downloaded the script.
Run the script (./bitwarden install) and answer all the questions till the end.
Finaly I start the containers using ./bitwarden start
System startes all the containers … but container bitwarden-mssql continously tryes to start
docker ps → (( bitwarden/mssql:1.48.1 “/” 13 minutes ago Up 50 seconds (health: starting) bitwarden-mssql))
also the container bitwarden-nginx and bitwarden-sso are unhealthy.
Now I Installed the BW for about 6 times … always facing the same result.
Anyone a clue what I do wrong …
Thank you in advanced fpr you help

You mention having the issues and when trying to rebuild the service running into the same issues.
Are you perhaps just stopping the service with the script and restarting it?

I would possibly suggest pruning all the docker images that would have been downloaded and cached on your machine, and then try to run the install script again and have it redownload the images and start again.

Perhaps something’s got corrupted during the image download, otherwise I’m unsure if the installer script provides an error log or if any information can found within docker.

Hey @mutohman - have you checked docker’s SQL Server logs?

docker logs bitwarden-mssql

You might get some clues as to why it fails to startup properly.

Also, since you did not mention it, did you remember to complete the post-installation steps?

Thx for you replay, I run through the log and there is an error with ipv6 connecting port 1433
#Server failed to listen on ‘any’ 1433. Error: 0x2742
In the Ubuntu 20.04 I disabled ipv6 in GRUB, after turning IPv6 on … resatrt the system … same problem.

What post-install process … ??

Check the link I provided above. Post-Install Configuration.

YAY … found the problem … mssql NEED to habe turned on ipv6!!!
in the bitearden LOG was the line: mssql Error: 26024, Severity: 16, State: 1
From Microsoft: KB4532432 - Mssql-conf tool fails if IPV6 is disabled on the Linux system

$ sudo nano /etc/default/grub
$ sudo update-grub
$ sudo reboot

Now it workes

Great news @mutohman. I’ll mark this one as Solved!