Browser crashed after second authentication via Yubikey

Hello, everyone,

I have enabled 2-factor authentication on Bitwarden, using “FIDO2 WebAuthn”, specifically via a Yubikey 5 NFC key.

If I access via Mozilla Firefox browser, there is no problem. If I do it via the same browser’s add-on, the login fails: I log in via device, sign in on my iPhone, it prompts me to open another tab, enter the key, and tap it, but then it crashes the whole thing and a padlock appears above the add-on’s bitwarden icon.

I have disabled all the add-ons leaving only the bit warden one active, but the problem persists.

Since it locks the bitwarden safe via add-on, if I close the browser but leave the Yubikey plugged in, when I start the browser it remains locked until I remove the key from the usb.

I am not a computer scientist, so my troubleshooting skills are limited.

I attach a gif!


Thanks to all

@Davide Welcome to the forum!

First, please be advised that this is a public forum, so you may wish to replace your gif with one in which personally identifiable information (such as your email address) has been obscured.

Second, for testing purposes, can you try to log in to your DDG browser extension using your Master Password instead of using you iPhone? Do you get the same error?

I thank you for your valuable advice, but for the email on the gif there is no need to worry as it is an address no longer used.

In fact, I tried accessing the add-on via master password and the anomaly does not occur, while trying passwordless access via device again the anomaly occurs.

What can this depend on?

For the time being thank you very much