Blocked IP

Below is a copy of an email I sent support today after been IP blocked last evening.

  1. My phone is in flight mode and not connected to internet. If I start Bitwarden, I can log in and still use my vault.
  2. My ip address is blocked and I have no access to your servers. If I start Bitwarden on my phone, I get a log on error message and I cannot use my vault.

Why are there any differences in how I can use your software in these two situations? If I could still use the app on my phone and only synchronization was disabled when there is no contact with your server, I could live with it. But it is difficult to still use Bitwarden in the future if I cannot thrust I get my work done.

So my feature request is to make sure the app is usable when it is not possible to contact the server for whatever reason.

I haven’t seen this scenario yet, but so far, as I read before, there aren’t issues with IP blocking to access the vault. That is, did it warn you that your IP address was blocked on a pop up message?

Anyway, I’d advise you to do this:

  1. Clear the app data and start from a fresh 1st run
  2. If it doesn’t work, try uninstalling and reinstalling the app again. The could make sure that it is not related to your device.

By any means, if only your phone got its IP blocked, try using a VPN service, such as ProtonVPN to test things and make sure your external IP address is blocked indeed.

Also, I’d recommend you to take a look on the posts tagged with this search criteria:

And this also talks a bit more about how accessing your vault offline works.

I got the message as shown in the picture when I tried in the browser. Before that I had tried to get into the app on two different phones. I opened the app and unlocked it with my fingerprint. I was then asked for to log in with my password instead of going directly to the vault. Log in with my password failed on both phones and I then tried to check for any outage messages in this forum, but was blocked. Half an hour later, everything worked again.

Wow, that’s pretty strange. I haven’t seen that happening before.


Did you try these?

Well, as you said this, I guess everything is fine now. But if you have further questions, don’t hesitate to drop by.

Maybe the system recognized it as a phishing or brute-force attempt for some reason (not really sure why), but since it’s working now, there shouldn’t be any issues.

Also, don’t forget to try with ProtonVPN in future cases. That may figure out if your external IP address is blacklisted or not. It might happen in some territories.

Tip: I guess your issue belongs more to User-to-User Support instead of Feature Requests. Try changing that tag, if possible.

I believe this user has resolved their issue but is submitting their experience as a feature request to prevent it from happening in the future.

Per the last line in the original post:

So my feature request is to make sure the app is usable when it is not possible to contact the server for whatever reason.

It does seem odd that a blocked IP address would prevent someone from accessing the app; as it normally is able to work read-only without an internet connection.

I am a new user to Bitwarden who recently switched from Enpass. If I understand you right, this error message I got is not common. I got worried that Bitwarden was a bad choice, but I suppose I could give it some more time before I make any conclusions

Several minutes ago I saw same IP block message like @stigvi
It seems the abuse system is a bit under pressure. Probably because many people like me are now changing many passwords because of the latest data breach.

It works again for me now, but it’s not kind of message you want to see when using your password manager.