Bitwarden.sh /dev/pts/0 error

Hi people.

I am installing a self-hosted Bitwarden server, following these instructions (Install and Deploy - Linux | Bitwarden Help & Support).

Installed docker and it is working fine, created the bitwarden user and everything as it should… but when I run the bitwarden.sh script, I get the following error:

“docker: Error response from daemon: failed to create shim task: OCI runtime create failed: runc create failed: unable to start container process: error during container init: open /dev/pts/0: operation not permitted: unknown.”

At first I noticed that by using ssh it would create a /dev/pts/0 file… so I tried running the script directly on the host (no /dev/pts/0 file) but still it made no difference… I have absolutely no idea what to do more.

Thanks in advance.

Hello @miguel.f.grilo - welcome to the Bitwarden community.

What type of hardware are you installing to?

It is a Rocky Linux 9 VM running on an ESX. 2 CPUs, 4GB RAM, 40GB Disk… dunno. Do you need more info?

That sounds pretty good, assuming those are x86 processors and not something else (like Arm).

Have you checked the log files yet? What do you see when you execute docker ps on the host?

Yup, its x86.

Any suggestion for log files?

docker ps (also with -a) gives me nothing. I mean, it only gives me the headers, but no container.

However, docker images shows me bitwarden/setup, because the script is able to fetch the image… it seems that it is when it tries to run the container that it gives the mentioned error.

Wow - that’s strange. I’m not sure what to suggest. You could hunt through the BW log files at ./bwdata/logs and see if anything jumps out, but I almost wonder if it isn’t worth trying a rebuild or full reinstall.

Or, you might just try Bitwarden support at:

Get in Touch | Bitwarden.

Hope you are able to make some headway on this!

No bwdata/logs folder for me :frowning: what do you mean by rebuild/full install? Regarding OS? Regarding Docker?

Ok thanks, I’ll contact them!

In case I find a solution I’ll post it here. Thanks for your help.

You should check back through the installation procedures you posted in your OP. It mentions executing bitwarden.sh rebuild as part of the installation process. Perhaps you missed this when you setup Bitwarden the first time? I don’t think that would cause this error, but worth a shot to execute it again.

Regarding the Bitwarden log files, if you installed Bitwarden to the default location, the logs should be in your home directory under the path ./bitwarden/logs. If there is no such folder, then you can check the docker logs - sounds like Bitwarden server has never actually been executed yet.

And when I say full reinstall, I mean wipe the installation you already performed and start all over from scratch.

I am having the same problem on CentOS 9. Did you find a solution?

Edit: It looks like a runc problem that should be fixed in v1.1.4.

Hi IsaacM. Sorry for the late response. Thanks for the info! Guess I’ll wait for the new runc release!

it is working after the new runc 1.1.4 release!!!

1 Like