Bitwarden on Android sometimes fails to auto-fill in a browser

Sometimes when I go to a site in a browser (e.g. Chrome or Brave) with a login form, BitWarden fails to recognize it and doesn’t populate the keyboard suggestion bar with a button to autofill the login.

When this happens, if I switch from the browser to the Android home screen and click the icon for the BitWarden app, then switch back to the browser, the keyboard suggestion bar then successfully populates with the autofill.

It’s as if BitWarden isn’t running in the background at the time I first go to the site with the login, and me manually opening it and then switching back to the browser fixes that and then everything works as it should.

I’ve read everything I can find about how to keep BitWarden running in the background and have already given it permission for unrestricted battery use in the background, which seems like it should allow it to always be running. But it still fails from time to time.

Once I get it working again as described above, it works for a while, but if a lot of time elapses between my last success and my next attempt, more often than not it will fail again.

How do I keep BitWarden running all the time so that it never fails to see login forms in a browser?

Thanks for any help.

| Modified to clarify the behavior is not specific to a particular browser.

I had a similar error a long time ago, so I don’t know what exactly I did to resolve the issue. Could you please give me your Bitwarden version and which Android you are using?
Also, which keyboard do you use? Have you tried if it works with another keyboard, since it doesn’t seem to be a browser issue?

BitWarden reports version 2023.9.1 and Gboard reports

Current version 123843698
Version = 2023061300

Android reports version 13, build number TQ3A. 230901.001, which is the latest September 2023 security update.

I suppose I could revert Gboard to the non beta version but this has been going on forever it seems so I don’t think its anything to do with a recent update. Other than Gboard I am not sure what other keyboard I could use. I prefer to stay with stock.

One thing I just noticed while replicating the issue is that it’s enough to switch out of the browser to the Android home screen and then, without doing anything else, switch back into the browser. Then the autofill populates the keyboard suggestion bar normally.

Thanks for responding.

| Updated to note that reverting Gboard to the non-beta version had no effect.

Hey @rlcronin

I apologize for the late response, I didn’t got a notification of your reply and just saw it coincidentally. :grimacing:

Which of the autofill settings do you have enabled in the app?

These are the autofill options I have:

I’m currently trying to reproduce your error but unsuccessfully yet. Do you have a few websites for me to test where autofill failed on your side?

I frequently encounter the issue at and

Since I still can’t reproduce your issue, I don’t think it has something to do with Bitwarden, but I will help you nevertheless :smiley:. It could be a problem with your mobile browser, Brave or Chrome.
Would you mind switching to PMs, since its off-topic for this community?

Try this. Open BitWarden. Switch to the Android home screen. Swipe up to bring up the recent apps carousel. Swipe the BitWarden card up to remove it from the carousel. Then try to recreate the issue at, say, USPS com. The swiping up of the BitWarden card seems to reliably cause the issue for me. You might say, don’t swipe BitWarden away. But I frequently get so many apps in the carousel that I need to clear it out to make it usable. I am not sure what happens to an app exactly when it gets swiped out of the carousel but it does seem to mess up BitWarden.

Before trying this, I need some of your settings in the Bitwarden app that could make a difference:

  • Tresor Timeout
  • How to unlock it (Master PW only, PIN, Biometry)

Just a screenshot would be the easiest if you upload it from your phone.

If by “Tresor Timeout” you mean “Vault timeout”, I have it set to “Never” (yes, I know thats bad practice but bear with me, at least for now, I will change it if necessary). And unlock is by Master Password only.

With these instructions and vault timeout set to never it still works on my side.

Sorry, I’m Swiss, so Bitwarden is set to German.
I thought that vault timeout is set to always or on restart of app could cause the error.

So lets switch to PMs and check if it’s a browser error or something other Bitwarden unrelated.

Switch to PM’s, okay with me, though I’ve no idea what to look at next as a possible source.

Good Morning,

I found this article by Bitwarden to troubleshoot the autofill:

According to @grb, it could also be a problem with match detection:

If both of them doesn’t solve your problem, contact the Bitwarden support, since your problem isn’t standard behavior.

Good luck & have a great day!

I had seen the troubleshooting article before. It didn’t help. I also tried out changing the match detection options to no avail. I will contact support.

I have this issue as well so would be interested in any solution.

For what its worth I contacted support and provided details of my issue. I just heard back that they have successfully recreated the problem. So hopefully this will help them find a solution. I was asked to fill out a trouble report at the following URL. Perhaps you might like to do the same.