Bitwarden is running on 2 domains?

I’ve discovered today that my self-hosted instance of bitwarden is running on 2 of my domains.

I configured a dynamic DNS on my cPanel for use with Bitwarden but I had quite a few problems getting everything working.

So I started from scratch with a new dynamic DNS and a new install of Ubuntu and then a new install of Bitwarden.

Somehow on my current configuration, both domains are serving Bitwarden. One, the first one has a warning that it’s not a secure site.

This one is:

The working install, the one that I’m using and have been using with the working certificate is:

My guess is this is why I’m seeing multiple nginx docker containers running:

0e82276b73c5 bitwarden/nginx:2023.1.0 “/” 8 days ago Up 6 days (healthy)>8080/tcp, :::8080->8080/tcp, 80/tcp,>8443/tcp, :::8443->8443/tcp bitwarden-nginx
720054d745de bitwarden/admin:2023.1.0

I need to make disappear or go away. Is this possible without trashing the working Bitwarden install? I feel like I was really lucky to get it working.

Thanks in advance.

I think you just need to delete the A record for from DNS (cPanel). Currently it appears that you have A records for both & pointing to the same IP address.

I have dynamic DNS set up for 3 domains on my cPanel. and are 2 of them. Since they are setup for dynamic DNS that’s the reason for the A record’s pointing to my IP address.

I did go in and delete the A record for and when I attempted to browse to the URL that was previously pulling up the unsecured bitwarden page is no longer doing this. When the dynamic DNS updated the A record for was created again but I tried to browse that bad page again and it’s still not working so I think it’s good. I’ve got no explanation for why this was happening but I guess it’s good now.

Thanks Reputably6121