Bitwarden disappeared from Safari 15 in Big Sur

I am running BW 1.28.3 (535). Mac OS 11.6. I get the blue badge, then it disappears when I reload Safari Version 15.0 (16612.1.29.41.4, 16612). No update shows available at all in App Store for BW?
Please can someone help?

Extension is now showing in Preferences, but not in the Safari window?

@MPV you may want to try running this to fix the launch services:
/System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user

@tonyt you may need to enable and restart safari. Make sure you’re running v1.29.1. The Appstore version is needed for TouchID to work.

I updated to 1.29.1 but it still didn’t show up as a Safari extension under Safari >> Safari Extensions. I found that I also had to go into Safari >> Preferences >> Extensions and re-enable Bitwarden there and then the blue shield was added to Safari. No scripts required :slight_smile:

Cheers H.

1 Like

I am also on BW v 1.29.1 and my Safari extension just disappeared, randomly, this afternoon (Nov 4).

BitWarden 1.29.1
Safari 15.1
MacOS 12.0.1

I tried the various fixes suggested including maintenance using Onyx. Nothing seemed to work.

EDIT: I just used Onyx to clear the Launch Services database and my extension returned!

Yeah, this did the trick for me.

So:

  1. Close Safari
  2. Run the command:
    /System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user
  3. Open Safari
  4. Go to Preferences > Extensions. It should be back in the list.

Thanks tgreer++

4 Likes

How do we know if the version we have is from the Apple store? If not, do we have to delete the app and then reload it from the store? Thanks

Welcome, @dabrown16!

For me, the easiest way to tell is by looking in the App Store. If the app store says ‘open’ - that usually means the download was from the App Store vs. direct download. If it says “install”, it’ll replace the current app with the App Store version.

Thank you. That helps. Looking forward to the fix.

For the record. Safari extension is working again with App Store version 1.29.1. Thanks, guys.

1 Like

Where is the fix? Waiting and waiting…

It works. Thank you

Same problem with Safari extensions not working in Safari 15 on a new MBP with M1 Pro chip.

I hope someone can fix this soon, I like BW but only if it works

Note: Your question may already be answered in the Bitwarden Help Center.

Just a reminder - All Enterprise, Teams, Families, and Premium subscribers receive priority support at bitwarden.com/contact :partying_face:

BW Loads as an app but safari extensions do not load, this On a MBP with M1 pro chip . It works on MBAir with M1 chip and MacOS 11. I hope someone can rebuild the Safari extensions.

Hi Tory - welcome!

You may have tried these workarounds already, but if not, one of them may fix things for you:

Onyx for MacOS works. Excellent and easy fix and it looks like a valuable Unility . Thank you very much!

1 Like

I got a new M1 MacBook Pro at the end of October, replacing an Intel based one. I’m running macOS Monterey with Safari 15.1 and Bitwarden 1.29.1 and this has happened three times during the past weeks. I never had the problem on Big Sur (or prior versions) on the old device.

The Bitwarden extension suddenly disappears and can only be brought back via the lsregister command posted above.

Whatever causes this issue hasn’t been fixed and seems to affect Bitwarden only – I’m using other extensions like Adguard and WebEx which don’t show this behaviour.

Are there any news what might cause this?

Thank you! This worked for me.

Can someone please share the Terminal command that fixed the issue?

@OhioN8v :+1: /System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user

2 Likes