Bitwarden disappeared from Safari 15 in Big Sur

The latest update of Bitwarden has removed the Safari 15 extension in Big Sur. I’m unable to even find the extension in the Safari Preferences. It worked fine until the latest update.

This happened once before. Is Bitwarden planning to update the extension so it works?

3 Likes

Hi @artiste212!

We’re keeping an eye out for reports of this. The last issue was attributed to Safari and other system caches. If you haven’t already resolved the issue, feel free to reach out to our CS team so we can help troubleshoot and perhaps work towards a root cause (if this issue is different than the previous one).

HI Tgreer,

I received an email from Bitwarden. They have a fix that involved running a command in Terminal that did the trick. At the same time, two other extensions that hadn’t shown up started to work, as well. I’m not sure of the cause, but there is a fix that they shared. I suppose it will be incorporated into a future update.Preformatted text

Hi. My Safari just now updated to 15.0 and now my Bitwarden extension is also gone… Can you share the terminal command that you used in order to restore it?

This is actually a different issue - we have a fix coming shortly to the desktop app - it’ll be available via App Store once addressed.

Stay tuned!

1 Like

Alright, awesome, thanks!

I just tried to rebuild the launcher services as described :point_down:, but no luck. Looking forward to the update!

Safari 15 on Catalina extension uninstalled itself · Issue #2113 · bitwarden/browser · GitHub

1 Like

I was able to get it back by replacing v1.29 with v1.28.3 from a Time Machine backup. Found the suggestion on reddit.

2 Likes

I’m having the same problem, Bitwarden extension vanished in Safari 15.0 (Mac OS 11.6.1).

Seems to be a recurring problem, so there are several fixes for several versions of Safari and Bitwarden. Tried most if not all, including rebooting, reinstalling Bitwarden, installing Safari Technology Preview, running OnyX to rebuild Launch Services database. No luck. As a cherry on top, restoring old version of Bitwarden from Time Machine brings back the extension but desktop app refuses to log in (with a “unknown error” or smthng).

Looking to replace Bitwarden with something more reliable.

This really is dissatisfying, since this would have submerged in proper testing with any new version of Safari and/or the Bitwarden client. For an app so critical to my workflow an extension disappearing should never happen. There was something similar (from a user perspective) with Safari 13. Three strike = out?

1 Like

Same here…hope it will be fixed soon !!!

Same situation here.
Annoying, happened before already.

Don’t mind the haters guys! looking forward to your fix :slight_smile:

1 Like

Bitwarden also disappeared from Monterey Safari, too. Like others, I was able to replace the current version with yesterday’s version using Time Machine, and it’s working once again.

This has happend a number of times over the past few years, so I’m hoping the fix this time is quick.

1 Like

Hey folks - thanks for keeping us alerted!

We have a fix queued and being submitted to the appstore now.

6 Likes

Same issue. My sweet blue shield vanished from my Safari toolbar last night. Thought I was losing it but now I see it’s a thing. Thanks in advance for the fix. :slight_smile:

Similar problem here. Absolutely love the program…

Remember this problem was created by Apple, not by bitwarden. Apple - The company whom I am increasingly disappointed in. My last apple product is the Air I just got. I hate it. My next PC will be linux based. Guarantee that.

Bitwarden are the hero’s trying to de-screw what Apple did. Keep up the good work guys.

2 Likes

Same problem - MBP 2019 (intel) running 12.0.1. Bitwarden version 1.29.0. Extension completely gone. Tried running the Terminal command given and restarting - no dice. It did not work.

Please fix soon!

1 Like

1.29.1 (fixed version) is currently awaiting review at Apple :+1:

8 Likes

Great! Look forward to the fix :+1:

Glad I found this thread, having the same issue. Good to hear a fix is on the way!