Bitwarden disappeared from Safari 15 in Big Sur

Hi

(should be fixed in 1.29.1, waiting for update)
Same issue in Monterey (both release 12.1 and 12.1 beta)
Safari Versjon 15.1 (17612.3.2.1.1)
Bitwarden 1.29 Versjon 1.29.0 (1790)

Hi
I had the extension working fine, saw an update on the App Store today, installed and blue badge has vanished!
Am on Big Sur latest and latest BW update. Same problem I guess!
Help!!!

This is a known issue folks, and it looks like the crew at Bitwarden responded right away with a fix. Everyone is just waiting on Apple to release version 1.29.1 in the App Store.

If you run Time Machine, you can replace Bitwarden.app in your Applications folder with version 1.28.3 to restore the extension while waiting for the latest release to be posted by Apple.

2 Likes

Bitwarden Safari extension disappeared from the toolbar, and I don’t see a way to add it in safari preferences.

Check your current version in Safari Extensions - App Store - Updates
If you see version 1.29.0 then you have to wait for update 1.29.1 where that issue should be fixed. Pls see attached screenshot

Update is now available from the mac app store.

If the extension didn’t come back, you might need to reregister launch services for Safari.

See: https://www.reddit.com/r/Bitwarden/comments/qip9cy/comment/hio98bq/?utm_source=share&utm_medium=web2x&context=3

Source: Disappearing Safari extensions

3 Likes

Thanks for the info I this issue and was like wtf

Thanks for posting @Baasd. I successfully updated to version 1.29.1 on the Mac App Store, and my Safari extension has returned and all is back to normal :+1:

2 Likes

Initially 1.29.1 didn’t solve it for me on Mac OS Monterey and safari 15. After installing safari technology preview the extension briefly worked on safari 15.
After a reboot of my Mac the extension is gone again.

How is this possible?

The tech preview bringing the extension back seems to indicate that running the scripts/onyx may solve the issue.

The 1.29.1 update solved that the extension wasn’t signed correctly, but the prior issue was around getting the extension to register with Safari correctly (which isn’t something we can solve from the app as far as I’m aware) and required running the commands in the GitHub thread above.

1 Like

Same here on Monterey after 1.29.1 update extension still missing.

I am running BW 1.28.3 (535). Mac OS 11.6. I get the blue badge, then it disappears when I reload Safari Version 15.0 (16612.1.29.41.4, 16612). No update shows available at all in App Store for BW?
Please can someone help?

Extension is now showing in Preferences, but not in the Safari window?

@MPV you may want to try running this to fix the launch services:
/System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user

@tonyt you may need to enable and restart safari. Make sure you’re running v1.29.1. The Appstore version is needed for TouchID to work.

I updated to 1.29.1 but it still didn’t show up as a Safari extension under Safari >> Safari Extensions. I found that I also had to go into Safari >> Preferences >> Extensions and re-enable Bitwarden there and then the blue shield was added to Safari. No scripts required :slight_smile:

Cheers H.

1 Like

I am also on BW v 1.29.1 and my Safari extension just disappeared, randomly, this afternoon (Nov 4).

BitWarden 1.29.1
Safari 15.1
MacOS 12.0.1

I tried the various fixes suggested including maintenance using Onyx. Nothing seemed to work.

EDIT: I just used Onyx to clear the Launch Services database and my extension returned!

Yeah, this did the trick for me.

So:

  1. Close Safari
  2. Run the command:
    /System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user
  3. Open Safari
  4. Go to Preferences > Extensions. It should be back in the list.

Thanks tgreer++

4 Likes

How do we know if the version we have is from the Apple store? If not, do we have to delete the app and then reload it from the store? Thanks

Welcome, @dabrown16!

For me, the easiest way to tell is by looking in the App Store. If the app store says ‘open’ - that usually means the download was from the App Store vs. direct download. If it says “install”, it’ll replace the current app with the App Store version.

Thank you. That helps. Looking forward to the fix.