Bitwarden Desktop Login issue on Ubuntu

I have an issue with logging in in the Bitwarden desktop application in linux. I have a self-hosted account and have no issue logging in from windows, android and the various browsers. However I am not able to login on a Bitwarden Desktop application I installed in ubuntu 22.04.1 LTS. I have tried to copy and paste the username, password and configuration in the browser on the same machine and and there the login works without any issue, while I receive the “password incorrect” message on the desktop app

Did you copy the same URL from your working browser into the desktop client’s Gear/Settings > Server URL? Settings is only visible after all accounts have been logged out of the desktop client.

Anything special about your server’s SSL certificate?

Yes, I did copy the same url (tried both ways even). I also tried to login in the browser extension and that worked as well without issue. If I put the wrong url in the desktop application the error message is different (failed to fetch, which makes sense). Id on’t think there is something particularly strange about the SSL certificate of the server, but even if, how would that explain this strange behaviour?

I tried to log in with bitwarden CLI as well, and see the same error. The error however does not show up if I login with the API key. In that case it logs in successfully (I did not try reading passwords though).

I have same problem. Problem to login in GUI (snap, flatpack, appimage) and also in CLI. We have self hosted server too. URL in settings is typed correct.

Regards Pavol

It would be really helpful if everyone posting in this thread could identify which CLI version and browser / browser extension they are using (including version numbers).

I am not seeing this on any of my clients, so it must be related to specific browsers and/or client versions.

It looks like everyone posting here is also running their server self-hosted. There have been reports that the latest Bitwarden clients are not working with non-Bitwarden servers. If you are running something other than Bitwarden server (e.g., vaultwarden), there may be issues and you should approach the support community of your software vendor for your server, please.

In my case:

Server version: 2.25.1 , only bitwarden server running

Windows machine (Windows 10 22H2)

  • Desktop version 2022.11.0 Working
  • Browser version 2022.10.0 Working
  • Web version Working

Linux machine (ubuntu 22.04.1 LTS)

  • Desktop version 2022.12.0 Not working
  • CLI 2022.11.0
    • login with username and password Not working
    • Login with API key Working
  • Browser version 2022.10.0 Working
  • Web version 2022.10.0 working

@Fede_Vill - That version of Bitwarden server is nearly a year old and could be deprecated, I would encourage you to update your server instance and see if that resolves the problem.

More details here: