Bitwarden always launches in 1st Desktop in macOS; want it to launch in the desktop I'm currently using

I have a MacBook Pro Max running macOS 12.4. I usually run 4 desktops and simply swipe between them as the task dictates. It seems all other apps open in the desktop currently displayed except Bitwarden. It seems to insist on opening in the first desktop regardless of which one I’m using. Not a big deal but swiping back and forth is annoying. It even switches back to the 1st desktop for the simple biometric entry popup.

I’ve tried uninstalling and reinstalling. Didn’t work. Uninstalled and removed all browser extensions. Didn’t work. Is Bitwarden hard-coded to open in the first desktop? Is there a setting of which I’m unaware?

Any help would be greatly appreciated because this has gotten under my skin!


Not super familiar with macOS, but I use multiple desktops on Windows for both personal and work.
Another reason the account switching feature was such a game changer for desktop

This was more of a specific setting within the Windows OS settings for multiple desktops and how to handle the application on each.
It seems the same may be similar for macOS, can you check if this works?

Assign apps to spaces

If you use two or more spaces, you can assign an app (or System Preferences) to a specific space so it always opens in that space.

  1. On your Mac, Control-click an app’s icon in the Dock. You may need to first open the app to show its icon in the Dock.
  2. In the shortcut menu that appears, choose Options, then choose one of the following:
  • All Desktops: The app opens in every space.
  • This Desktop: The app opens only in the current space. If you use the app full screen, it appears in its own space.
  • Desktop on Display [number]: The app opens in the current space on a specific display (if more than one display is available).
  • None: The app opens in whichever space you’re using at the time.

By default, when switching to an app, the desktop automatically switches to a space that has open windows for the app. For example, if you create a new TextEdit document in Desktop 3, but TextEdit windows are already open in Desktop 2, your new document opens in Desktop 2. To change this setting, choose Apple menu > System Preferences, click Mission Control , then deselect the checkbox for switching.

Beautiful! Worked like a charm. You made my day… this has been such an annoyance, and you solved it for me. Thanks!