Autofilling ID requires Master Password?

New here. Can someone explain why I need to enter my Master Password when trying to autofill an identity? There’s nothing secure about my name or email address. I can’t find a setting to edit that requirement, either. Sorry if this is basic, but I’m stumped. Thanks.

Hello and welcome to the community!

The clients are all set up to lock automatically after some time has passed, and unless you set up to unlock with PIN or biometrics, it’s automatically locked with a master password.

The vault, while in locked state, is encrypted in memory, and it can’t fill anything for you, so you will need to unlock it first. Here are the ways to set up to unlock with a PIN or biometrics:

People also have set up the clients to never lock, but this is considered less safe. Also, there seem to be more bugs related to keeping this kind of settings in the recent releases.

Thanks for responding so quickly, but I think my question wasn’t clear. I meant that I’m logged in and Bitwarden is autofilling passwords easily and without requiring entry of my Master Password, but when I try to autofill my work ID (e.g., full name, work email, etc.), I’m required to enter my Master Password again. Thoughts?

In the identity that you are trying to use, do you have the option “Master password re-prompt” checked?

1 Like

Nope.
image

So, when you are trying to auto-fill with identity, you follow this right?

  1. Click browser’s extension icon
  2. Click on identity
  3. BW prompts for master password?

If this is the case, have you tried clicking on the view icon, and then autofill at the bottom?

I have tried autofilling identity’s information on a few forms ( e.g. RoboForm Tutorials - Form Filler: Filling Your Information into Online Forms with One Click ), but none of them prompts for a master password. The behavior you observe sound like a bug. There was at least one identity filling bug released after 2024.4.1. I would file a bug on Issues · bitwarden/clients · GitHub .

I am testing using BW extension 2024.4.1 on a FF 115.11.0ESR

Correct, and here’s the appearance:

It sounds like this is a bug, so I’ll open a ticket. Thanks for trying!

1 Like

@knbz @Neuron5569 And I think I can add something… nosily as I am, I wanted to check out this also… I never really used the master password-repromt, but this option is almost completely gone for me now - I don’t see it in the browser extension, not in the web app, not in the desktop app… only the mobile app shows me still this option.

Something’s not right here. :face_with_spiral_eyes:

Are you sure that you opened the Edit page (not just View)?

Yes, edit page.

My browser extension (2024.4.2, Brave, Windows 11), “edit” for an obviously almost empty entry:

1 Like

“New entry” from the desktop app (2024.4.3, Windows 11):

PS: Web vault the same… but I was too lazy to login there as well, again :sweat_smile:

PPS: I reported my observation in GitHub now.

2 Likes