Autofill fills password for asus router twice

When I use BW to fill my asus router login, the password gets put into the password field twice.

Can this be fixed?

Hello @OldSurferDude,
can you save your router page and attach it here? I would like to inspect it and see what is causing that.

If you mean the url,. it is

http://(internal LAN ip address)

I tried to inspect the page (chrome --) but there is not much to it. here is a screen capture asus login screen capture|398x500

Would you be able to get access to an ASUS router?

No, but I can inspect the behavior by having the html page that’s why I asked to attach the html page ( you get it from the menu File > Save page as). With that I can check if the behavior also persist on my bitwarden (in Firefox).

The url is irrelevant for this case.

If you worry about security, there is nothing to worry about attaching the login page (without a password) as it is just a view and nothing from your router is written there (settings, etc).

How do you fill in your password for the router? Right click, CRTL + Shift + L or via the extenssion?

I have chrome, I got this by [right-click]–>[view sorce page]

Is this what you are requesting? Thanks for your help!

(too long to upload)

Hello @OldSurferDude,

I served the site with nodeJS and created dummy username and Password.
No problem observed in Firefox and the site itself seems to have no problem.

Can you check your saved password settings, maybe it lies there the problem.

I’m not sure what you mean by “saved password settings” Do you mean the bitwarden entry? The password I have for it in bitwarden is correct. I can auto fill, but the password is entered twice. If I go to bitwarden and copy the the password then paste it into the password field, it works.

I just tried it with firefox running on mint. I created a new entry in the default manual way (+ in upper right corner). That puts the in password twice, too

I appreciate your help and curiosity!


I mean here:

This is strange, If you created a new entry then it should not be the problem of the saved credentials.
One Idea that I have now is, that maybe the password has special character like \ or } which might cause the problem. Although very unlikely, would be a fun bug though :smiley:.

If you can try to login on a totally different device, and see if it still occurs.

Sadly I don’t have a definitive solution :frowning:.

You could try to login with another browser like Internet Explorer, Safari or Firefox to see if this is a browser issue.

yes, strange it is very long, and has at least one of every character: (regex [a-Z],[0-9],[$],[%],[^],[&] )

I’ll file this in "mysteries to be solved after I’ve solved things I can solve.

(MetBril… Note above that I did try firefox running on Mint