Auto lock not working properly

Has the Bitwarden browser extension for Chrome OS been updated very recently? For the last few days, the extension has stopped auto locking after the specified timeout period. I have the timeout for auto lock set for 15 minutes. Yesterday I restarted my Chromebook and then it seemed to be working for the rest of the day. However this morning I found it unlocked again. Is anyone else noticing this problem in the last few days?

@JoanB Welcome to the forum!

Version 2024.4.1 was released last week. There is usually some delay before the new releases are approved by the app stores (e.g., the Chrome Web Store), so it is possible that your browser extension would have been updated “very recently”.

Do you ever use the “pop-out” button (shown below) to create a stand-alone extension window? If so, Bitwarden’s time-out timer will not consider your extension to be inactive until you close that window.


I may have used the “pop-out” button when I was looking for something in Bitwarden. I have 3rd party pop-ups blocked in my settings. I also do have the uBlock Origin ad blocker installed - not sure if that matters. If you think that pop-out in Bitwarden is causing the problem, I’ll be very careful to make sure I manually close it.

But this never happened before the last few days, so might it still have something to do with the latest update?

It’s possible. However, on Windows 11, the 2024.4.1 version of the Chrome browser extension does not have this problem.

If you find your extension to be unlocked when you think that it should have timed out, check to see if there are any Bitwarden browser extension windows (either attached to a browser or “popped out”) that are still open.

As an experiment, you could also try setting the time-out interval to 1 min, close all extension windows, and wait for one minute to see if a padlock :lock: symbol appears in the corner of the Bitwarden browser extension’s shield :shield: icon at the top of your browser.

I tried what you suggested about changing the timeout interval to 1 minutes. I tried it a couple of times, and it did lock. I’ll keep an eye on it and see if it’s unlocked again after the Chromebook has been idle for a few hours.