Auto-fill is taking away focus from input field

The new auto-fill feature is great, but I’m finding that it tends to take away focus from the input field when it should not, making navigating and using a web page’s input fields a pain.

For example: if I click in the username input field in Safari, the auto-fill feature kicks in, and focus is now given to the first option in the auto-fill dropdown. This should not happen. I clicked in the text field because I want to type something. Instead, I now have to click in the field twice: once to give it initial focus, but then have to click it again to return focus which was stolen by the Bitwarden.

I am on the latest version of Safari, on the lates version of macOS.

What setting are you using for the inline auto-fill option (“Show auto-fill menu on form fields” under Settings > Auto-fill)? Have you tried changing it to “When auto-fill icon is selected”?

Also, I’m not sure I understand your use-case: If you’re clicking in the username input field, why would you not want Bitwarden to auto-fill a username into that field?

1 Like

Thank you, @grb. I feel silly for not seeing that Setting. That worked!

1 Like

No worries, glad I could help. FYI, I’ve moved your post out of the Feature Request section and into the Ask the Community section, and marked your question as “Solved”. :white_check_mark: