Attachments with bitwarden desktop app for mac os x

I have purchased the Premium Bitwarden account in order to store attachements with some entries.

It works without issues (except the annoying message every time I click “attachements” in the Desktop app which reads “this feature works only with premium accounts”).

However, I don’t see any sign or icon indicating that an entry has an attachement vs another one which does not have attachment.

To figure out if the entry has an attachement, I need first to “edit” the entry, then click the “Attachements” link to see if an attachement is present or not.

Am I missing something? I would assume that an attachement icon (paperclip or so) would indicate which entries have attachements.

Thanks for your insight

I have an identity vault item set up with an attachment and it does show a paperclip icon next to the name:

image

Not sure if I have any login-type entries I can check :thinking:

Thank you for your response. Actually, I now see a paper clip to the right of the entry but due to the layout of my Mac OSx bitwarden desktop app, i had to expand my column width to see it.

In the capture below, only the first one has an attachment. But without expanding the column width I was not able to tell.

On the phone also (Android), I had to put it landscape mode so the paperclip showed.

I wish there could be something more obvious or maybe to the left of the entry, or some kind of bold appearance.

Many thanks for your reply.

Lanceloz,

I’m having a similar problem. How did you ‘expand your column width’ on the Mac OS client so you could see the Attachments icon? I’ve not been able to figure that out.

The whole app window is resizable (which expands the columns) and responds to browser zoom commands (like cmd + and cmd - zoom in and out :+1:

Thanks. I had tried that and the paperclip still did not appear.
However, after restarting BitWarden the paperclips are now showing up on my desktop, but the paperclip is not clickable. Some progress.

I see that the Item Information has an ‘Attachments’ section where I can download the attachments. Still not able to attach a new file.

Editing an item and clicking on “Attachments” should open a new window that will allow you to browse for a file and upload it.

1 Like

Good source of info on attachments:
https://bitwarden.com/help/article/attachments/