API not working with Remote Desktop Manager

I’m trying to configure Remote Desktop Manager from Devolutions to connect via API to Bitwarden for getting some credentials.
I initially contacted the dev from Devolutions, they state it work from their side and can’t reproduce the error. Then they asked me to try deactivating MFA for test purpose. I refused.

I’m using hardware token authentication (Yubikey) but I don’t know how it could interfere since Remote Desktop Manager is supposed to use the API with a secret.

Do someone here successfully configured it?

PS: The error I get from RDM is “Unable to retrieve Bitwarden credentials”.

Hey @Spi,

I would make sure you are using the vault management API which is needed for management of Vault items, and not the Bitwarden public API which is used for things like Organization management.

Here is a screenshot of the configuration:

I tried to change the host field by the value below just to test, without success:

None of these settings works and I’m using the key as described on this page. Sound like the good keys from my point of view.

Without being familiar with Devolutions, it appears that the Host section you are referring to would be for the Bitwarden server URL where you account is hosted.

This is hard-coded for the Bitwarden cloud SaaS offering, but can also be changed to a specific URL of you self-host your own Bitwarden server.
i.e bitwarden.company.com

So I would likely leave this blank for the default, or enter your own URL if you have a self-hosted server.

I also located these few resources from Devolutions that may be of assistance in explaining a bit more.

As well as a Devolutions community forum post regarding the topic.

Hope this info helps :slightly_smiling_face:

It confirm that I’ve setuped it correctly.
I also found this link so apparently the issue is on your side.

Could you follow up with your engineers please?

Hey Spi, you might be bumping into this issue: Unusual Internet Traffic | Bitwarden Help Center (includes steps to resolve)

Well I don’t think it’s this.
I don’t use VPN, Tor, nor proxies and I already tested with differents IP.

I also don’t have any connection issue except for RDM. Web browser, web extension or the software is working.

I’m opening a ticket, we’ll see.


I’m one of the Devolutions developers working on the Bitwarden integration.

Just jumping in to provide a little more information on the issue, as we’ve been stuck on this for quite a while now.

The actual error that Spi is getting is “System.Net.WebException: The request was aborted: Could not create SSL/TLS secure channel.” It’s happening when trying to login using the endpoint “connect/token”.

As for the host field, if nothing is specified we use “https://identity.bitwarden.com” for the login, and then “https://api.bitwarden.com” for the vault synchronization.

I’ll be happy to provide any more information to help solve this issue.


Hi @jdelsignore , apparently it’s a different issue.
As always when it come to provide clear informations about their licensing, Bitwarden miss the point and give false informations.

After opening a ticket to the support, apparently and if they did understand correctly the question… We need to use the API Key from an organization to use the connector Devolutions designed.

I don’t see any API available for my free organization, despite I’m a premium user.
From what I understood I need a paid plan like Family or Enterprise to have an API available.

To Bitwarden team: I’m really fed up with the level of support you provide and the lack of clear instruction in your documentation. Even your own employee get lost and said anything to close a ticket without solving the request properly.

Actually it’s the opposite. An organization key won’t work with our integration, only a personal API key can be used.

Well, I don’t know what to say honnestly.
The Bitwarden support confirmed that is only working with enterprise key.
On the other side, your integration is working for some customers… so one way or another, we missed something.

Maybe it’s only working with pro account that is part of enterprise plan ?

Jordan from the Bitwarden Integration Engineering team here. Just to mention, the above is not accurate, and this specific integration will use a User API key, not the Organization key - user API keys are available for all Bitwarden accounts.

@jdelsignore I wanted to check in with you about the error message that you reported seeing when this integration is set up; that looks like a connection reset error, rather than any error code related to the Unusual Internet Traffic Help Center article linked by my colleague earlier. Do you have a full stack trace with the raw communication that’s occurring so we can confirm whether this is a TCP-level reset or if perhaps the error code you provided might be trying to mislead us and there is a server-side error response being sent that we can investigate further on our side? Although it would not be the case for this use-case, if there was some sort of plan limitation, it would have an error code in the response and not just a hang-up of the connection.

Feel free to open a private channel of communication with me if that’s easier - you can fill in the contact form (Get in Touch | Bitwarden) and ask the ticket be routed to me based on my feedback in this thread.

Still no news on the topic?


Sorry for the late reply, but we just had another user that had the exact same issue, and they were able to solve this by setting the server to TLS 1.2. There’s an issue between .Net 4.8 and TLS 1.3. Here’s the post for more info : Devolutions Forum


Well, do your servers use TLS 1.3 ? Since I just tried and get the same error as usual.