Android Bitwarden App Connection Failure

I have been using the Bitwarden Android App for about two years now with my self-hosted server. I keep the server isolated to an internal LAN-only network, and when I need to access via my phone, I connect to my VPN on my firewall. Then I can access it via the web or apps, etc, as everything is set up via DNS that is issued via the VPN. My setup worked fine until the most recent version of the Bitwarden Android app. 3.2024. (most recent from Play Store) Android OS 10

When I connect to my VPN, the new app pops up with an exception message:connection failure. I am not sure if it is not resolving the host’s name. I checked the settings on my phone, and it has the pushed DNS. I can ping via hostname via terminal, access the web portal via Chrome, etc. However, the Bitwarden app will not connect. I have wiped off Bitwarden and all data, rebooted, and it’s the same thing.

If VPNed in via laptop and the Windows app resolves the hostname just fine, connects and syncs…

Not sure if the app doesn’t use the pushed DNS or if there is something else occurring.

Bitwardedn Server is on 2024.2.3
Using OpenVPN via pfsense to connect to the network.

I hooked up a usb c to ethernet adapter to the phone and same result. I can ping through the terminal server, etc, but the app still will not connect.

I am not sure what occurred, but I wiped all certificates off the phone and reinstalled my CA cert that I used previously (still in the downloads folder on the phone), and it’s now working again. Not sure why this would have just gone bad unless that cert was bad/expired on the device. Posting this follow-up just incase someone else runs into the issue

Hi @kilthro,

I think I am running into the Same issue. While I use an letsencrypt certificate for my vaultwarden Installation I get the Same Error Message whenever I try to Connect to it with the Android App. However IT works fine with iOS.

Can you Tell me whether there were any additional steps necessary to make it work for you?

My cert is through Go Daddy (domain is through them). I downloaded the bundled cert and installed it by tapping it for apps/vpn. This installed the Go daddy g2 authority certificate. In my case, the one there either got messed up or didn’t update correctly. I’m not sure. But once I removed the old cert and reinstalled it, the app immediately started working again. Now, keep in mind for the Android app, the name on the cert may need to match the name on the URL that you are using to connect. I could be wrong. I remember in the past running into that issue I believe. So make sure the names match or you can run into issues. IE cert issued to mybitwarden.domain.com and the URL that you are using in the custom URL box is the same.