Android app log in: Chain validation failed

I have installed the Android version of Bitwarden from the Google Play store onto a brand new phone (TCL 20S) running Android 11. Kernel 4.14.190-perf+. Nov 1, 2021 security patch level.

After I enter my credentials and click “Log In”, I get a pop-up error message with title “An error has occurred” and body:
Exception message: Chain validation failed

It sounds related to the SSL certificate chain. I checked the Bitwarden web site and of course I’ve Googled this message too. It seems typically related to self-hosted instances, which is not what I’m trying to do. I’m just trying to access the public Bitwarden service.

Is my phone perhaps missing trust for a root CA or something? It’s brand new, a 2021 model, and I ran all the updates.

Thank you.

Hello @chief-b - welcome!

Sorry to hear you are having issues. Is there any chance you were self-hosting bitwarden or vaultwarden in the past?

Nope, I have never self-hosted. The phone is pretty much in a virgin state. I took the phone out of the box, installed all my favorite apps from the Play store (including Bitwarden) and then launched BW, tried to log in on the normal (not enterprise or self-hosting) login page, and then got the error. I have tried uninstalling and re-installing the app as well.

It’s fixed - sorry for the bother. And thanks for the warm welcome. I’ve used Bitwarden for years and love it! I’ll leave some more detail in case it ever helps a Googling straggler as desperate as I.

I determined the issue was completely unrelated to Bitwarden after I noticed other a handful of other apps behaving strangely as well. Netflix for example, log-on worked fine, and all the metadata about the various shows I could watch, loaded, but no thumbnails. My bank worked, except after tapping an account, the transaction list was blank. My weather app was completely borked, no forecasts at all. Most apps, including YouTube, browser, etc. seemed just fine.

I did a factory reset and now Bitwarden works.

My guess is something screwy in the network stack that perhaps only impacted certain domains(?) I haven’t the foggiest idea what it could have been, or what might have triggered it on a new phone, but there we are!

Glad to hear you got it working! That was a very odd issue, and honestly I was not sure what to suggest! :smiley:

Just for future reference… this feels like it’s a DNS issue, where IPv6 worked, but IPv4 didn’t for some reason. We had similar issues in our local network because of the local DNS server.