An unhandled server error has occurred

Good night, I installed bitwarden on ubuntu server 20.04 , on TRUE NAS CORE 12.0 U8 virtual machine and the installation and configuration works without any errors or apparent problems.

Now when I enter the site and try to make a registration or an invalid login I always get this error:
An unhandled server error has occurred .
In page inspection mode inside the error gives status code 500

However, I noticed that if you access https://192.168.8.4, you enter the page, but if you enter https://srv.bw.com (what I defined), I can’t find the page.

Ubuntu has internet I’ve already turned off ipv6, I’ve already reinstalled 2 times I’ve put fixed ip and dhcp, I’ve already defined google’s dns always the same problem.
There was already 1 time it worked but when rebooting the machine and it came back to the same.

I installed vmware on my pc installed the same iso and same manual with the steps and it works fine.

What’s going on here?

thanks

Hello @dio123 - welcome to the community forums.

What installation method did you follow? Can you post the details or a URL to the process?

Also, what sort of hardware is this running on?

hello @dh024,
My Hardware is intel celeron j3455 with 8gb ram where I have the TRUENAS primary system and VM mount inside. The VM ubuntu server is configurate 30gb disk and 2 gb ram.

I follow this method How to Install Bitwarden on Ubuntu 20.04 – LinuxWays

One thing I found strange is that in ./bitwarden install, if i choose to use let’s encrypt generate ,
I get an error that the ports are not open, but it doesn’t make sense because we are working on an internal network, and truenas doesn’t have a firewall, but I turned off the router’s firewall to test and it gave the same error.

However, I have internet, because the youtube.com ping test is ok, and I can download updates from the ubuntu website.
Is it a problem that docker is not bridging correctly to the enp0s4 connection where I receive the internet.
thank you for your help.

Hi @dio123 - thanks for the info. I am not familiar with that installation guide, and I didn’t go through it step by step to ensure it is accurate (it may be), but I suggest that it is always better to use the official installation instructions from Bitwarden:

Otherwise, your system sounds like it should work fine for hosting Bitwarden.

I have never run TrueNAS myself, so I am not familiar with how it configures the virtual network for your VM, but it sounds like it works fine if you can access BW via the internal IP address. If you can’t access it using a computer name (e.g., https://srv.bw.com) then it sounds like a name resolution issue. Have you enabled port forwarding on your host system so that ports 80 and 443 are being forwarded to the VM instead of being used for a host-specific web server (e.g., a management page)? And is your DNS entry pointing to the host machine’s IP rather than an internal IP?

If you still don’t figure it out, I would suggest trying the official installation instructions and see if that helps.

Good afternoon,
I created a new installation and followed the steps in the official installation link.
In the ./bitwarden configuration I was able to generate the certificate in let’s encrypt without error, and I can even enter by dns name instead of ip.
Before starting I went to global.override.env and edited.
[email protected]
globalSettings__mail__smtp__host=smtp.sapo.pt
globalSettings__mail__smtp__port=25
globalSettings__mail__smtp__ssl=true
[email protected]
globalSettings__mail__smtp__password=*********
globalSettings__disableUserRegistration=false
globalSettings__hibpApiKey=REPLACE
adminSettings__admins=my email

Then I saved and started, when I go to create an account / or do recovery I get the same error:
An unhandled server error has occurred
Detail error in firefox:
https://192.168.8.3/api/accounts/password-hint
error:500
Internal Server Error
VersionHTTP/2

I use these emails in truenas, ups, my cloud alerts, and they don’t have any special settings like gmail and outlook.

Port 25 is typically for unencrypted SMTP traffic. Have you tried the port specified for SSL/TLS traffic instead?

Good afternoon,
thank you for help.
Something strange happens,
on the 24th I managed to install it with the let’s encrypt certificate and it generated the certificate successfully.
I configured outlook email in globaloveride by adding the lines below.
cglobalSettings__mail__smtp__trustServer=true
globalSettings__mail__smtp__startTls=true

I did bitwarden rebuild and followed start
I managed to register by logging in, validated my account and received the emails successfully.
I managed to access externally and configured my cell phone. I reassembled the server 2 times and both times it booted and worked.

Yesterday I started to configure the computer and the mobile all working well.

Today I turned off the pc, fixed it in the final place, turned it on and when I try to login I have exactly the same error, without making any changes.

An unhandled server error has occurred.

I am aslo facing excatly same issue when saving passwords in bitwarden mobile android

Hello @faizhameed - welcome to the community forums.

From what other users have reported, often this error arises because of network latency or other issues. Have you tried switching networks? For example, if the error occurs on wifi, try switching to mobile data or another wifi network to see if the problem persists.

This can also occur if you are hosting your own bitwarden server - or do you rely on the Bitwarden cloud to store your vault data?