An error has occurred. An unexpected error has occurred

Hey guys.

I’m hosting my vault on my synology. This worked for more than 2 years without any problems, but yesterday I got logged out and got this message while I tried to log in again


I tried multiple things:

  • Updating the docker containers
  • I thought it was my SSL with Cloudflare (it wasn’t)
  • Redeploying my containers
  • Create a new user and try to log in (Same issue)

Are there any logs saved somewhere?
Or does anyone know what could be the issue potentially?

Kind regards,


@Mailootje Welcome to the forum!

Which version of Bitwarden Server are you running? See instructions for determining server version.

Version 24.1.1

That is the version of the Web Vault client app, not the server. Please screenshot the Dashboard of your Admin Portal, which displays your server version.

Do you know how to check on a docker composer instance? Because I can’t find the version. I also tried the bw -v command in the console of the docker, but that also didn’t work.

What happens if you navigate to (with “yourname” replaced by whatever host name you are using)?

Nothing. I got this error:

I’m using these docker images

It might be best if you contact Bitwarden’s customer support for help.

1 Like

Were you able to resolve this issue? I got the same problem after self hosting for 2 years and a few container upgrades and now I can’t log into my self host version of bitwarden as well.

Im right now contacting the technical support. They may think it’s an permission issue. But I’m investigating with their technical support and hopefully we can find the problem soon.

If you are running the latest version 2024.1.1 try downgrading to version 2024.1.0.

I downgraded my docker container image to:


And now everything works again.

What a pain in the ass…that worked. Thanks!

1 Like

Their own support doesn’t even reply anymore….

But I’m glad it worked for you :upside_down_face:

Just wait for the next 1.2 update. Hopefully that update will work flawlessly.

Also make backups of your containers etc. You will never know. If the installation or database becomes corrupt you will lose your passwords etc.

Thank you very much. Downgrading worked for me.
But I am facing now the problem, that I am unable to use a newer version than 2024.1.0.

2024.1.2 - container is starting, unable to create entries: Unhandeld server error
2024.2.0 - container is starting, unable to create entries: Unhandeld server error
2024.2.1 - container is not even starting (unhealty) - Probably the MariaDB error (latest beta mariadb error · Issue #3651 · bitwarden/server · GitHub)

Back up everything and export your passwords and other items. Remove everything and perform a clean installation. Afterward, it should work. Then, simply import all your passwords and other items.