Allow Bitwarden to work fully with Amazon Smile login page

Feature name

Allow Bitwarden to work fully with the Amazon Smile login page.

Feature function

Currently, Bitwarden does not seem to be able to check the rememberMe checkbox input field in the Amazon login page.

I have tried adding this field as a custom field with the name rememberMe, and even tried to get Bitwarden to recognize it using a matching regex. Neither method works.

Amazon is one of those websites, that even after entering your unique long password, still insists on forcing you re-enter your password during the current session to perform certain actions. The rememberMe checkbox fixes this Amazon annoyance, but Bitwarden doesn’t currently seem to be compatible with this checkbox.

Related topics + references

The URL of the login page with the “Remember Me” functionality (“Keep me signed in” label) is:

https://smile.amazon.com/ap/signin?openid.assoc_handle=amzn_smile&openid.identity=http://specs.openid.net/auth/2.0/identifier_select&openid.mode=checkid_setup&openid.claimed_id=http://specs.openid.net/auth/2.0/identifier_select&openid.ns=http://specs.openid.net/auth/2.0&pageId=default

BTW, if anyone knows of a shorter Amazon Smile login URL that includes the “Remember Me” functionality, feel free to post it.

1 Like

I believe that Bitwarden issues a virtual mouseclick into the checkbox field after the auto-fill action has been completed, and that this is the source of the problem. The event listeners on the Amazon login page apparently toggle the state of the checkbox when it is clicked. Fortunately, this allows for your problem to be solved:

Create a custom field of the Boolean type, named rememberMe. Set the state of the boolean to false, by leaving the checkbox cleared. This works, because Bitwarden will now auto-fill the checkbox as false, but the virtual mouseclick will cause the state of the checkbox to toggle to true.

Let us know if this worked for you (it worked in my testing, on a Chrome browser).

4 Likes

Thank you so much for your response. I will definitely try what you wrote, and write back.

I also really appreciate your technical explanation of what you think is happening. I had to read what you wrote a few times for it to sink in, but what your wrote now makes good sense.

1 Like

I was truly hoping your suggestion would work. Unfortunately, in Firefox 106.0.1 (current release as of this writing) with Bitwarden 2022.10.1 (also current release as of this writing), that trick did not work.

I created a new boolean custom field named rememberMe, and set the boolean value to false (unchecked), but it did not work.

To experiment, I also tried creating a new boolean custom field named regex=^r.*, but that didn’t work either.

I’m open to more ideas or, of course, a fix from the Bitwarden team.

1 Like

Sorry to hear that my Chrome solution didn’t work in FireFox. I don’t have the FF extension currently, so I can’t do any further testing. If you have access to a Chrome browser, perhaps you can test it there, just to check that the issue lies with FireFox, and not your computer. Also, what OS are you using? My test was in Windows.

One more test to try — if you haven’t already done so, repeat my Chrome fix, but make the Boolean checkbox checked (true). This is supposed to do what you want it to do, if the “virtual mouseclick” phenomenon does not occur in FF. There could be other issues getting in the way, but if you haven’t yet attempted the autofill using a checked checkbox for the Boolean rememberMe field, then you definitely should try this.

3 Likes

I believe there may be something else very strange going on with Amazon smiles webpage, Firefox, and Bitwarden.

Amazon’s login page is one that is a bit strange, if you login with Bitwarden to allow auto-fill, Amazon’s login screen presents an email or phone number for your user account. This is auto-filled by Bitwarden and then will automatically sign you in without your “password” section showing.
Bitwarden loads the password in the secondary password field which is presented behind the scene of the first email option which is why this doesn’t show.
I’ve seen a few other webpages that interact this way though without issues.


On Firefox and with the Bitwarden extension attempting to login to the Amazon smile webpage gives some very odd behavior.
As mentioned the Boolean custom field typically works for remember me check boxes like this.
I could not get any form of this to work, though oddly enough I did get the remember me box to get checked when filling with another entry.

In trying to figure out the difference between the two login entries I tested numerous different variations, with and without URI matching, TOTP seed, etc.
I was able to narrow down, that oddly enough if you try to have Bitwarden auto-fill on the Amazon smile page, and the username does not match the given username at the login screen, then the password auto-fill will “check” the remember me no matter what. :face_with_monocle:

FUPvLH3X0AAnjbI

2 Likes

Great job here trying to break it down!!

2 Likes

Thank you for your response. I apologize for the 2 week delay in mine. Life, you know. :wink:

Sorry to hear that my Chrome solution didn’t work in FireFox.

Thanks. Me too.

I don’t have the FF extension currently, so I can’t do any further testing. If you have access to a Chrome browser, perhaps you can test it there, just to check that the issue lies with FireFox, and not your computer.

I’m in the opposite situation. Easy access to FF, but not to Chrome. It would be exceptionally unlikely that it’s a computer specific issue, especially given the response from @cksapp that came in after your post.

Also, what OS are you using? My test was in Windows.

I tested on Windows and Linux.

One more test to try — if you haven’t already done so, repeat my Chrome fix, but make the Boolean checkbox checked (true). This is supposed to do what you want it to do, if the “virtual mouseclick” phenomenon does not occur in FF. There could be other issues getting in the way, but if you haven’t yet attempted the autofill using a checked checkbox for the Boolean rememberMe field, then you definitely should try this.

Great minds think alike (or not-so-great minds… you decide :wink: )… I had already that, and it didn’t work any better.

The response from @cksapp below is fascinating. I need to read it another half-dozen times (what’s that it metric?) to fully make sense of it. After doing that, I plan on responding to their post. I hope you continue along with us on this little journey.

Thank you again.

1 Like

Thanks so very much for your response. I’ve read it a half-dozen times, as promised, and here is my response…

I believe there may be something else very strange going on with Amazon smiles webpage, Firefox, and Bitwarden.

For better or worse, I am very, very, very familiar with the coding of the front end of the Amazon web site. In my opinion, it’s what happens when management is too afraid of touching much in fear of breaking everything. It’s a messy hodgepodge of clutter that would benefit from a fire followed by a flood (metaphorically speaking).

Amazon’s login page is one that is a bit strange, if you login with Bitwarden to allow auto-fill, Amazon’s login screen presents an email or phone number for your user account. This is auto-fill [sic] by Bitwarden and then will automatically sign you in without your “password” section showing. Bitwarden loads the password in the secondary password field which is presented behind the scene of the first email option which is why this doesn’t show. I’ve seen a few other webpages that interact this way though without issues.

Hmmm… I’m not experiencing this. Using the URL I provided, I see a password field. When I use Bitwarden to fill the page’s fields, the password field appears to fill as expected for me.

Perhaps you are talking about a different URL? If there’s one thing Amazon loves, it’s having 10 different URLs to go to the same page, or pages that are almost the same, but not identical. I occasionally wonder if Bezos thinks he gets a free luxury jet every time he makes things more complicated than they need to be.

On Firefox and with the Bitwarden extension attempting to login to the Amazon smile webpage gives some very odd behavior.

You have my attention!

As mentioned the Boolean custom field typically works for remember me check boxes like this. I could not get any form of this to work, though oddly enough I did get the remember me box to get checked when filling with another entry.

In trying to figure out the difference between the two login entries I tested numerous different variations, with and without URI matching, TOTP seed, etc. I was able to narrow down, that oddly enough if you try to have Bitwarden auto-fill on the Amazon smile page, and the username does not match the given username at the login screen, then the password auto-fill will “check” the remember me no matter what.

Okay, this is intriguing, and sounds like it may be a Bitwarden bug.

I’m not completely sure I understand exactly what you are trying to convey, so I’m going to play with what I think you are saying to see if I get a similar outcome.

Feel free to write some more details to help guide me or Team Bitwarden.

BTW, if anyone from Bitwarden is reading this, can you confirm whether or not this a bug in Bitwarden, please?

Hey @bit you can contact the support team at Get in Touch | Bitwarden or report specific autofill failures for the team to investigate here: Autofill isn't working for a specific site · Issue #1621 · bitwarden/clients · GitHub, specifically in this form on the Github page: Report autofill failure

1 Like

I would suggest “and” (not “or”), i.e., do both. I have used that GitHub form on a few occasions (and recommended to users here that they submit such reports), and it seems to be a bit of a black hole. If the team is actually using the submitted data to modify the auto-fill algorithm, I would recommend that release notes include information such as “Fixed auto-fill issues that could occur on smile.amazon.com, www.psecu.com, and www.reddit.com.”

1 Like

Thank you. So the Bitwarden team doesn’t use these official Bitwarden forums anymore?

I took a look at the “Contact customer service” form, but it seems to create a private thread, which will prevent others from benefiting or being able to contribute; I find it more productive to work as a community instead of in isolation.

I also took a look at the “Report autofill failure” link, but it still uses Google Forms. I’m not sure why a sensitive tool like Bitwarden would choose to use Google for anything (given their history of privacy violations) when there are so many better choices, but I have nearly all Google servers blocked, so using that form isn’t trivial. I did ask a colleague to submit a site via that form over a year ago, and like @grb mentioned, it was a black hole.

I’m still hopeful that maybe someone from Bitwarden actually looks at these official Bitwarden forums. If not, I doubt I’ll use them very often.

Yes… black hole… my experience as well. And it still uses Google, which is bad form (pun unintended). See my post to @grb above.

1 Like

Forum members that have the Bitwarden emblem on their profile picture actually do work at Bitwarden. And one of them - dwbit - already replied to you.

1 Like

Ah thanks. But that Bitwarden staff member said to use a private contact form outside of this forum to contact Bitwarden staff to resolve this issue. So confusing. Why not just discuss it here where the issue has already been posted so everyone can benefit from seeing the discussion and progress, instead of working with me privately in a vacuum? @grb and @cksapp have skills, knowledge, and experience to contribute. Others here in the community as well. Let’s leverage everyone’s skill and experience to build a better Bitwarden.

To be fair, this website is a community forum, in which the community of users help each other. The support contact form and the Github repository are the only channels available for direct communication with Bitwarden technical support staff and developers.

Our valued community member @bw-admin is a social media manager “Technical Evangelist” for Bitwarden, and serves as a liaison between the user community (here, and on Reddit) and the team of developers and tech support staff at Bitwarden. He can relay user concerns to the team, but apparently has no power to summon developers to the forum. :wink:

In certain cases, developers will chime in on these forums, when they are not busy developing code for Manifest V3… :scream:

But for now, Bitwarden has decided that their developers’ time — for the most part — is not best spent on social media… :sob:

@bit thanks for your patience, my comment above included both the official Bitwarden support channel from the Bitwarden website, as well as a link to the public Github repo, where you can report an issue directly. The autofill-failure form is optional and not required to submit a bug report.

While you will occasionally see developers responding directly to threads, often times they are working on engineering issues. There are many feature requests and community conversations ongoing at all times, but rest assured I have shared this one with the team :+1:

1 Like

Sorry for the delay in response here,

You are correct, in the URL provided in the initial posting I get both an Email or mobile phone number and Password sections. Both of which auto-fill with the Bitwarden FF extension, but does not fill the boolean custom field for rememberMe as one would expect.


I am indeed! I simply utilize the base domain https://smile.amazon.com, though initially for amazon smile I have my launch URL set to https://smile.amazon.com/ap/signin which used to work as a direct sign in page, but appears to no longer work.
Bummer :confused:

Sorry for the confusion, in order to recreate my steps do the following:

  1. No Amazon login has the Boolean custom fieldrememberMe

  2. Create a secondary amazon login entry in Bitwarden, minimum requirement seems to be a “Username and Password”, which does not have to be legitimate data, and the URL for https://smile.amazon.com

  3. Proceed to the smile.amazon.com website, select the Sign In option.

  4. Manually type your amazon login, NOT auto-filled.

  5. Either select the auto-fill entry from the extension, context-menu, or with Ctrl\Cmd + Shift + L

  6. The password is auto-filled, but the Keep me signed in. option does not get checked as you would expect.
    (This also does not work if you have the boolean field in FF which is the entire concern here)
    Repeat step 5. and auto-fill with the second login.

  7. Miraculously somehow the Keep me signed in box is checked! Even without any custom field.

These are my discoveries in trying to troubleshoot this issue. Do with this information what you will, but again I am not sure as to why this is or where the problem may lie.
Safe to say though some very strange and unexpected behavior to say the least.

P.S. By the way, the above steps with having two logins does not work when it was tested with the URL you provided initially that has both the Username and Password sections together, so all around even more strangeness. :weary:

1 Like

Although Amazon Smile was discontinued by Amazon despite the protests of the many charities the program was helping (boo Amazon), the login issue with Bitwarden persists.

If the good people at Bitwarden, or our helpful community, want to work on making Bitwarden fully compatible with Amazon login pages, I can post the current URIs that are broken.

1 Like

If the URL that you are having trouble with is not smile.amazon.com, I would suggest starting a new thread. FYI, I have no trouble using Bitwarden to log in to Amazon (using Chrome).