6 years later and still can't import secure notes?

I am listening to Steve Gibson’s Security Now and guess what - I decided to migrate from LastPass to BitWarden. Unfortunately I get a weird error about some note being bigger then 10000 chars. I check the CSV file and it has only couple hundred, so WTH? The message does not give any explanation or advice what to do, so there goes any user friendliness and I have to go crawl the ancient github bugreports in search for answers :frowning: Found two very old threads

explaining that the note is bigger then 10000chars AFTER the encryption and some ppl put there clever Python scripts as a workaround. That’s all great, but you really think that normal non techy people will have any chance of importing their LastPass vault when there are obstacles like this? Absolutely not! I think it would really be great to stop being lazy and finally fix the import functionality to be able to work with secure notes OR at least give a clear instructions what to do about this! It can also be an apology that these notes just cannot be imported, but they can be skipped and the rest of items would import. Can someone please code this? These bug reports are many years old!

1 Like

If I try to add the same secure note via the desktop app IT WORKS without any error, so I don’t see any reason why it can’t be imported from the CSV file.

Which desktop app did you try that this worked on? Did you simply copy the plain text into a secure note on the desktop app, or did you mean you did this with the desktop app being the Bitwarden Importer Tool?

I was following Import Data from LastPass guide. There is no mention of this tool, so I didn’t know it exists. I just copied the text of that one secure note from that Lastpass CSV export which was mentioned in the error and pasted it as a new secure note into standard Bitwarden Windows app without problem. Let me see if this importer works any different then the Web vault…

So I have installed the importer tool and it worked! My whole LastPass vault was imported without any issue, so thanks for the suggestion! Seems like it uses different algorithm then the Web vault.
So I suggest the devs to do the following:

  • fix the web vault import functionality and until it’s done point people to this desktop app
  • correct the Field size import errors paragraph in the guide because it’s confusing. My note was only about 450characters and it triggered the error. It’s not possible to shrink that one anymore without losing information.
1 Like