2FA enabled, but does not ask for TOTP

Hello,
I’m on a free plan and enabled 2FA with an authenticatior in the vault.bitwarden.com.
The setup went fine, including confirming the Enable with a 2FA TOTP.
But when I log out and log back in to vault.bitwarden.com, it does NOT ask for 2FA, even though I successfully enabled it. What’s going on there?
Thanks for your help.
Peter

My best guess is that you activated the “Remember me”-option:

image

To get 2FA back go to the settings of your browser, search for cookies and in that menu search for vault.bitwarden.com. Once you have found it delete Local storage.

Thank you Peter_H, you were right. I had forgotten about “Remember me” (beginner here).

One other thing I don’t understand: Why does 2FA only work for vault.bitwarden.com, but not for the browser extensions, the desktop app, or the mobile app?

Isn’t that a security weakness? If someone had my password, they’d simply try to crack one of those apps not protected by 2FA?

Or will 2FA work on all apps in the premium plan?

Once activated on any platform 2FA does work for all instances no matter where you use Bitwarden; unless you used that Remember me-option. You can choose different settings for every instance. For example: On all devices I have chosen not to use the 2FA-Remember me for vault.bitwarden.com. But I did activate it for 2FA for the extension in my main-browser and the desktop app both at home and on my mobile. On my computer at the office 2FA is always enforced.

If however 2FA still does not work for you try to log out and back in on all those places. If this did not help go to vault.bitwarden.com, then go to Settings -> My Account and scroll down to the Danger Zone. Click onto Deauthorize Sessions and then wait “for up to one hour” (quote from the pop-up) and try again.

Fantastic, that solved all issues.
I had tried before to log out from all applications, but that didn’t do the trick. It took the “Deauthorize Sessions” to reset everything.
Thanks so much for all your explanations, Peter_H!