2 factor does not work

I tried to log in to my bitwarden. But i am using a 2factor with email.
for some reason the codes i am getting arent valid.
It also takes ages for the email te recieve.
Please help. I need to get in!

It is never a bad idea to start by rebooting your device (s). I have no idea if time, date and time zone are relevant for those codes. It still will do no harm to check all 3 of them and to make sure that they are set correctly. If possible use the same network you used when you set up 2FA.

When you set up this 2FA method you received an eMail with a code which you had to enter to confirm that this actually works (*1). Only after this 2FA for eMail was activated for you.
Meaning: At least at one point this must have worked as intended.

You also were offered to “View (the) Recovery Code”. You were also told its importance and to write it down:

Do you have your Recovery Code ? Use it if your 2FA method continues to not work for you (*2).

For the future: Get at least a 2nd form of 2FA which is completely different. This way you always have a backup for 2FA if one method fails you. I personally have activated all methods with the exception of eMail (as I consider this not a safe method) and still create a weekly backup (*3) of my passwords.

If your data is important to you treat it accordingly.

(*1) Two-step Login via Email | Bitwarden Help & Support
(*2) Recovery Codes | Bitwarden Help & Support
(*3) Export Vault Data | Bitwarden Help & Support

1 Like

I was able to get in again. And right away i saved the recovery code… and used a authentication app. So things cant get wrong now.

Thanks for the replay

1 Like

Things can always go wrong, but now it is much more unlikely to happen.

TOTP works fine but its slower and you have to hit more “buttons” to login when compared to U2F. I leave a Yubi inserted on my home machine and logging in is virtually instant when using it. I don’t save the BW password so I don’t feel leaving the Yubi in my machine in my home office is any significant risk.

TOTP is my backup method and that is on another device. When using that form of 2FA I require two devices. Works for me anyway!