Vault timeout not working

Same issue here. Firefox 97.0.1 with Bitwarden 1.55.0.

Came to Bitwarden from Lastpass, and these are the little things that are going to make me go back to LastPass and pay Premium there

I’m experiencing vault timeout on browser restart regardless of settings in the extension:

Windows 10
Chrome Version 98.0.4758.102 (Official Build) (64-bit)
Bitwarden 1.56.6
Basic Free Account

I’m using BW 1.56.6 and the latest Firefox 97.0.1 and it’s still locking me out all the time, regardless of what settings I have for security.

Looks like 20 days ago this was supposed to be fixed “soon” What is the status??

If I set the lock to Never, it says that the master password is stored online. Does that mean that a hacker could get at it? Or, if I prevent anyone else from using the computer, is the master password safe?

This is driving me crazy enough to drop my premium membership!

Hi @kat2022 can you try reinstalling the extension?

Hi dwbit, thanks for the reply. Do you mean reinstall BitWarden? I have a file called Bitwarden-Installer-1.23.1

Is there somewhere to get the latest version?

Thanks!

In Firefox, trying removing the extension and reinstalling.

I just received an email from Bitwarden support saying “This is a known issue that we’re working to fix within our next update.” So I guess we just have to live with it for now.

Nothing works except changing the option to “Never.” and if Rosa got a recent email saying they’re working on it, guess that’s why.

I’m wondering how vulnerable I am if I set it to Never. Here’s the status message I get: Are you sure you want to use the “Never” option? Setting your lock options to “Never” stores your vault’s encryption key on your device. If you use this option you should ensure that you keep your device properly protected.

When it says that it stores the key on my device, what does that mean? Is it stored in the clear somewhere? Could a hacker find it?

Just an update: although I posted I had this “spontaneous random auto-locks” issue with BW extension version 1.56.6 as well under Chrome, in my case it looks now the issue is not there anymore. However please note that although BW extension did not change, Chrome did update and restart before the issue (apparently) disappeared.

fab - is your lock setting set at Never?

no, I keep it set to “browser restart” (see above) and almost never restart the browser since I always just send my MacBook to sleep so that it’s instant-ready when I come back - after some troubles everything seems fine now - don’t know why.

I have just switched today from LastPass to Bitwarden and it is annoying as hell as I am having the exact same problem and am having to input my password everytime I close my browser. I want to add a custom timeout of 720 hours but it doesn’t work…

Problem Scenario:
Browser: Firefox 98.0 (64-bit)
Extension Version: 1.56.6
OS: Windows 10 Professional

Hello @plague - welcome to the community forums!

Just to check - you made sure to disable the Lock with master password on restart option in your extension settings, right? If not, that might explain the behaviour you are seeing.

Screen Shot 2022-03-01 at 11.54.18 PM

I don’t use the PIN to login. But I tried it, unticking the box you showed, but nothing changed and I still need to input a PIN if I close and re-open my browser.

You will always have to unlock your browser with a PIN or your master password if you close it. The reason is that your key is stored in memory attached to the browser process, and if the browser is closed your key to decrypt your vault will be removed. That’s a very safe way of securing your secrets.

There is an option to set the vault timeout to NEVER, which will store the key in persistent storage on a drive, which is somewhat less secure. But if your device is physically secured, you might wish to do this to avoid unlocking the vault whenever the browser is shut down.

I use the chrome extension and it doesn’t matter what time I choose to lock the vault, it doesn’t lock. I think this is not secure. If I put my macbook to sleep mode and wake up later the vault is still open. This forces me to lock the vault every single time by hand. So my problem is opposite. The vault doesn’t lock.

exact same problem for 1.57.0 on Chrome on M1 Macbook Pro 16" using in clamshell mode(not sure if this makes a difference). Very frustrating for an otherwise excellent tool. hope it’ll get fixed soon. Trying out v1.55 to see if it fixes it.