Vault Lock Issue

My vault would lockon automatically in 1 minute, but when I press the “PASSWORDS GENERATOR” botton by chance, I realize that i can enter my vault without verifying, witch means the vault didn’t actually lockon before I press the botton

To prove it, I made such a experiment

  1. Unlock my vault
  2. Wait for a minute
  3. Press the Bitwarden icon, and the vault is already lockon, I have to input password or verify fingerprint
  4. Unlock again
  5. Wait for another minute ( actully 2 min, to make sure )
  6. Press “Passwords Generator” botton
  7. I entered the Generator without verifying, and I can also view every thing in my vault, just like enter the vault in dailytime

Which means the vault won’t lockon sometimes

Now I setup my vault to lockon immediately, and this have never happen again

Android Beta 2.14.3

My phone:
Redmi K20pro
MIUI 12.5.6 Based on Andriod 11

[email protected]

That is very strange! I tried replicating this behaviour on Android 11, Bitwarden 2.14.2, but I am forced to authenticate when I use the generate password button. Perhaps ensure you have updated the app?

It’s Android Beta 2.14.3, I checked again.
And there are another posibility, it’s cause of Xiaomi MIUI system, I just did the same on another Xiaomi divice, which is MIUI 10 based Andriod 8.1, and it’s happend again, but it’s still need more evidence and testing.

Sorry, but I did follow every step you did, and I cannot get the error to occur.

Using Pixel 6 Pro running Android 12 vanilla (sec update 11/5/21)
BW (Android) v2.14.2(4005)

Hey @ZYDai how about you get off the beta and try the release version, see if you can recreate it on that and then we can get your phone out of the way in terms of a source of error?

It’s might not be the problem of APP or Android, you should try to test it on Xiaomi device, all the Chinese cellphone or tablet are basically not built on original Android system, they are all modified from Android, I’ll try to testing more device and reply sometimes later.

I also couldn’t recreate this bug. Good luck figuring out the exact cause @ZYDai .

Sorry, I don’t have a Xiaomi phone, just the Pixel. :frowning:

Alright, I have to contact with Xiaomi.

This problem have beem solved, might be the fault in bitwarden cause I didn’t update my system since then, it’s solved in latest version, anyway, this problem are done.