Unable to login after update

I first stopped bitwarden using ./bitwarden.sh stop, did updateself and update. Did a updatedb and did a restart.

My settings seem to have been kept when I look in bwdata/env, it should be able to mail (as it always has for admin login).

But I can’t login to the addon, or the web vault, or the admin page. I always get “An unexpected error has occurred.” I can’t create a new account (same error).

I rebooted the server even, restarted docker, everything starts, docker ps shows them all up and running.

I ran the update because bitwarden was getting extremely slow, opening an item in the vault would take minutes before popping up the window, and then another minute for it to fill the popup with details.

Any ideas what might be going on?

Thanks!

What is the output of docker ps? Also check the logs for API and Identity to see what the error is about.

Thanks, but I have no idea where those logs are.

I can execute a shell on those containers as root, but where are the logs I need to check? i’ve checked some of them but I’m just running around blind.

Is there any documentation that will help me troubleshoot and provide more info on log location etc?

Output of docker ps:

CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
9f7b0983cb13 bitwarden/web:1.26.0 “/entrypoint.sh” 12 hours ago Up 12 hours 5000/tcp bitwarden-web
b75b7b821702 bitwarden/identity:1.19.0 “/entrypoint.sh” 12 hours ago Up 12 hours 5000/tcp bitwarden-identity
ecbff1c77b8a bitwarden/attachments:1.19.0 “/entrypoint.sh” 12 hours ago Up 12 hours 5000/tcp bitwarden-attachments
e73d5872c503 bitwarden/admin:1.19.0 “/entrypoint.sh” 12 hours ago Up 12 hours 5000/tcp bitwarden-admin
7d8d06bf00fc bitwarden/nginx:1.19.0 “/entrypoint.sh” 12 hours ago Up 12 hours 80/tcp, 0.0.0.0:80->8080/tcp, 0.0.0.0:443->8443/tcp bitwarden-nginx
5f4210f9faa5 bitwarden/mssql:1.19.0 “/entrypoint.sh” 12 hours ago Up 12 hours 1433/tcp bitwarden-mssql
357f7c2333c9 bitwarden/api:1.19.0 “/entrypoint.sh” 12 hours ago Up 12 hours 5000/tcp bitwarden-api
2298819a0106 bitwarden/icons:1.19.0 “/entrypoint.sh” 12 hours ago Up 12 hours 5000/tcp bitwarden-icons

Thanks for the help!

An update: My firewall was blocking port 587, so mail wasn’t getting out. I fixed that and I was able to login as admin.

However, there are no users.

Is there any way to see why that happened or to get it back?

Thanks.

Another update. I see my backups shrunk since yesterday. I think I need to restore the one before that.

However, (i never worked with MSSQL) I need some help to do this. In my struggles I tried:

1> ALTER DATABASE vault SET RECOVERY SIMPLE;
2> go
1> RESTORE DATABASE vault
2> FROM DISK = ‘/etc/bitwarden/mssql/backups/vault_FULL_06012018_000003.BAK’
3> WITH FILE=1, NORECOVERY;
4> go
Msg 3154, Level 16, State 4, Server 19e34fea9334, Line 1
The backup set holds a backup of a database other than the existing ‘vault’ database.
Msg 3013, Level 16, State 1, Server 19e34fea9334, Line 1
RESTORE DATABASE is terminating abnormally.

What are the commands to do this?

Thanks!

Nevermind.

I don’t want to deal with this. I deleted it.

The idea of self hosting is cool, but having to deal with Microsoft proprietary software not only bothers me, it’s just too much hassle and I don’t want to learn it.

You write a free, open source tool which is awesome but decide to use Microsoft proprietary software on Linux - I don’t mean to sound disrespectful but that is a choice I will never understand. There are really good, free, open source alternatives that work just as well … if not better.

I could have easily managed this on MySQL or Mongo or even Postgres.