Twitter auto-fill issues

Sometimes when I’m using Twitter app on Android, Bitwarden offers to save as password the terms I entered in search bar there. Also, when I click in the search bar so I can type, Bitwarden show my login credentials.

It seems Bitwarden is mixing up the search bar as a password field. I just ignore it, but as it is a bit annoying, is there anything I can do to avoid that behavior?

1 Like

Hey @ludens thanks for letting us know! Which language are you currently using in the app?

Hey @bw-admin , thanks for your response! I use Brazilian Portuguese language.

Thanks for confirmation! The team is aware of the issue and looking into it.

1 Like

Thanks for acknowledging the issue. I’m just writing to let know that this is also happening in Spanish (us) language on Android.

1 Like

Thanks all, I’ll send the follow up notes to the team :+1:

Have this as well in Dutch (e.g. when searching in Twitter on Android)

1 Like

Russian language interface have this problem too. Please, help us, because it’s really annoying.

1 Like

Hey everyone, after investigating, it appears this is based on how Twitter has set things up on their end. It doesn’t look like there is much we can do except everyone who is affected report directly to Twitter.

It appears this is a Twitter issue related to incorrectly labelled fields, often presenting for specific languages. You can use linked custom fields or tweet @TwitterSupport or the Twitter support page.

1 Like

I understand that autofill is an experimental feature, but I’d expect that it would work for some of the most visited sites. Surprisingly it doesn’t seem to work for Twitter and instead I have to manually fill my username and password. My suggestion is to fix this and implement autofill for Twitter.

Both and the Twitter mobile app work perfectly for me. I would check your process.

1 Like

When you go to Twitter in a web browser, does it show this ? image
If it does not you should correct the URI.

1 Like

The issue for me is only the username field. Bitwarden simply cannot find it, I need to type it manually and press “Next”, than auto-fill works with for the password field.

Just to double check, what language are you using? The Twitter framework seems to have been incorrectly configured for several languages which results in things like the Twitter search field acting like a password field etc… which is out of our control.

@bw-admin, I agree with @Maxim. I too can’t get Bitwarden to autofill the multi-page login sites such as twitter & disney+. Another friend of mine also complained of the same. So, I know for a fact that this issue is not local to one person or device.
Also, FYI I’ve excluded Bitwarden app from any optimization that my Mi 11 Ultra does (running MiUI 13) and have given all permissions and even enabled auto start. Still, no luck. Tried multiple times so far.
Please take a look at this & kindly fix this or suggest a fix. Thanks!

Hey @VVR it works as expected on my end using both browser extension and mobile app. What system language are you using? We did isolate an issue where Twitter has not configured the field names correctly on web and app for certain languages (which Bitwarden does not have control over).

Feel free to use the forms in either of these two Github issues to share information for the team to investigate:

1 Like

@bw-admin, I’m using English (India). So, should I change this to English (United States) or other regions mentioned in my MiUI settings?

You can also try using custom linked fields to resolve the issue as it relates to the way the website has labelled certain fields.

Linked custom fields can be used to solve issues where your browser extension can’t auto-fill usernames and passwords for a particular site.

@bw-admin, I finally managed to figure out something. This is happening mainly when I’m using “Brave” browser on my Android phone. I just tried “DuckDuckGo” browser and the “in-lay” autofill showed up with my credentials. So, not sure how to fix this. I tried checking all possible settings but I’m unable to figure out a solution.
Any advice? Please let me know. Thanks!