Turn off Auto Update on Mac OS

Hi everyone,
Because of a graphics card failure I have a MacBook Pro which is stuck on Mac OS 10.12 (Sierra).
I have found that the Safari extension doesn’t work with this old version of the OS so I have tried to install an older version of Bitwarden. Sadly the auto update prevents me from doing this.
I would like to request that it should be possible to turn the auto update feature off.

Thanks, Steve

Thank you for your post!

Feature name

  • Enter the name/concept of the feature being requested

Feature function

  • What will this feature do differently?
  • What benefits will this feature bring?
  • Remember to add a tag for each client application that will be affected

Related topics + references

  • Are there any related topics that may help explain the need and function of this feature?
  • Are there any references to this feature or function on other platforms that may be helpful?

Currently there is no way turn off auto updates. Updates will be automatically installed on your PC after it has been deployed by the company for offering users maximum security and convenience. If there was a switch to turn off updates, most users won’t even bother to update which is not a good choice.

Thank you for your response. I appreciate that updates and security are paramount in an application which is storing sensitive information, so you make a fair point.
If, however, auto updates were ‘on’ by default then those users you sight, who would not update, would be unlikely to to turn updates off, but at least those that needed to for sound operational reasons, such as myself, would have the option.

I understand you are in a pretty bad situation, I am not a mac user so I really cannot do anything. Will Apple fix the graphic card? It maybe expensive but it seems like the only option. or maybe you can switch to Linux?

You can disable auto-update via an electron environmental variable:

Sorry, I was not aware about this.

Thank you, It could be worse! I think Apple reluctantly fixed this problem for a while but not any more. I think I will move that machine to Linux, at some point, but it’s OK for now.

I am also interested in this, but for Windows.