TOTP Not Working iOS/MacOS - Clock set to Automatic

I can’t get TOTP working on my iPhone, iPad or Mac Mini. Using Twitter I set up the 2FA Authentication with Bitwarden (Premium). However when I try to paste the code into Twitter it always responds with an error that the code isn’t correct. All these machines have the date/time set to Automatic and the time and time zone are correct and location services are turned on.

Now I’m locked out of Twitter (which may not be a bad thing :smile: ) until I get this figured out.

Update: I just did a remote login to a computer at work that was still logged into Twitter. I was able to change the 2-factor authentication app from Bitwarden to 2FAS. And that app WORKS! So as far as I can see, the problem is with Bitwarden and not with the time setting on my devices.

Hi @Mtl_Biker, welcome to community! :wave:

How did you first set up TOTP with Bitwarden? If you manually entered a secret, perhaps there was a typo or an added character?

I would recommend trying to re-add the TOTP and use your mobile app to scan the QR code when it comes up and see if that helps.

If that doesn’t work, our support team would be happy to assist.

I was having trouble setting it up… first with my iPhone, after scanning the QR code and adding it to Bitwarden, I was unable to get to the field in Twitter to enter the code. It was just at the bottom edge of the screen and partially covered by the onscreen keyboard. I tried and tried and simply wasn’t able to.

With my iPad there was no problem getting to the field to enter the code (after scanning the QR code and getting the TOTP code from Bitwarden.

So it seems it was properly created/entered in Bitwarden. However, when I tried to log in and Bitwarden had copied the code and I would paste it into Twitter, Twitter would always respond that the code was invalid. Online help suggested it was a clock/time issue and I confirmed that the clocks on my iPhone, iPad and Mac Mini were all set to automatically update.

Yet the code generated would never be accepted. I’ve been waiting for a reply from Ben about this since Sunday night and early Monday morning and so far there hasn’t been any reply. I finally gave up, installed 2FAS, that that is working just fine (so I don’t think it’s a clock issue).

I’m disappointed though about Bitwarden. I became a Premium subscriber a month ago because I liked the program and wanted to support it. This was before I knew anything about 2FA systems. The lack of response from them about this is disappointing. Ben initially replied within minutes of my reaching out, and he stopped replying after several exchanges without offering any solution. I wrote to him Sunday night to tell him that with the iPad I had been able to set it up, but that the code was always being rejected. No reply from him. I followed up Monday morning, and again earlier today, and still no reply. I think he/Bitwarden has given up on trying to help.

And I’m disappointed.

TOTP is a relatively simple implementation in Bitwarden so shouldn’t be too difficult to troubleshoot - particularly if you have it working in a different authenticator. A few suggestions -

  • Compare the TOTP seeds between your working authenticator and Bitwarden (Edit view). If your working authenticator won’t let you view the seeds, set up a different authenticator - I use Raivo for iOS. Make sure the seeds between the two apps are the same.
  • Compare the codes generated between the working authenticator and Bitwarden. Again, this is where Raivo would be helpful because it shows you the current and previous code (just in case they’re slightly out of sync due to clock differences). The codes should cycle at exactly the same time between the two authenticators if there is no clock issue.

Unfortunately we don’t really pay Bitwarden enough to expect them to hold our hand through all of the many user-specific issues that can complicate TOTP. But the good news is that as I explained above, so long as the two seeds are the same and the device clocks (and timezones) are identical you should be fine.