[Solved] Android app no icons for logins

Refreshing the vault does not resolve the issue. I uninstalled google play version. Installed f-droid version directly from Releases · bitwarden/mobile · GitHub.

I installed Version 2.13.0 f-droid file: com.x8bit.bitwarden-fdroid.apk

Issue persists. No icons. I miss having icons and hope we can get this issue resolved. Thank you!

@tgreer Please don’t abandon this thread. My icons still missing on all android devices. Please help resolve this issue.

Thank you!

Not abandoned - I promise!

We’ve resolved the issues with our icon server, and so far haven’t had repeated reports of this occurring.

Would you be opposed to doing fresh install after a reboot to see if the icons are there?

Ok. Here’s what I did:

  1. Log out, clear cache, clear data, uninstall
  2. Reboot device
  3. Reinstall app, log in

No icons!

I’ve always been a fan of bitwarden, but very disappointed in the lack of interest in helping me resolve this icon issue.

@Collence - apologies for not being more active here. We haven’t seen any further reports of icon issues.

For more troubleshooting, you may want to reach out to our CS team so they can dig deeper and ask more specific questions.

Same issue here. Icons on PC work flawless but no icons on my android phone, android tablet or the android phone of my dad.
Cleared cache etc. didnt resolve my problem. I also debugged the app with fiddler, it is not even trying to make a request for the icons.

Coming here to chime in - I am having the same issue, I just got a new phone and the issue persists there as well, icons show up on web interface, on PC/browser add-in, but not on the android phone app.

Thanks for the updates everyone!

Not sure if @mp-bw has any ideas on this one.

I also debugged my network traffic and can confirm the android apps ( phone and tablet ) are not making any calls for icons. Did same test with Web and IOS and I see the icon calls.

Very odd indeed. After some checking, could those using the play store version give the beta app a try?

All seems copesetic in our latest version - but it would be great for those having the issue to confirm :slight_smile:

Updated to beta. Still no icons.

Thank you @mckraemer - we’ll keep looking.

I don’t know about any of the others here but I suppose I should disclose that I’m running BitwardenRS server to host my own BitWarden, but I assume if that was the casue someone else here would have also mentioned it, but I guess I’ll chime in anyways :wink:

The issue is with the andoid app. It is not making icon calls. It’s been verified through network debugging. The question is what happened? The android app has worked fine for years. Why has it stopped making icon calls? There are no errors, it’s not making the calls. I surmise this is much more widespread, just that many are not reporting it. In the code is there a flag somewhere that was accidentally flipped to prevent icon calls? Please have your QA team check this out and work with the dev team on a fix. Thank you!

FWIW, I have three android devices and icons are working fine on all of the, and I have never noticed this problem before.

@dh024 I’m pleased it’s working for you. However, many of us are not having an equally satisfying experience on our android phones. Clearly, there is an issue on android phones for many customers. You’re one of the lucky ones who is not impacted by this issue, but for those of us who are, we would appreciate attention to this matter.

1 Like

Yes, I understand and I am very sorry this is happening to you. I just wanted to chime in with my experience so that people can get a sense of how widespread this is. No offense or insensitivity intended!

1 Like

Latest android update today I tested again, still no luck.

If I turn off the icons in the settings I get the generic “globe” icon for all entries, but if I turn it back on there’s just a blank space, no icons at all still.

Same exact behavior after update. Something is going on with android apps which is breaking the icons. It’s not affecting everyone, but is affecting some users. I’ve checked network traffic and no icon calls are being made. My android apps worked perfect for many years. One day it just broke not to long ago. Strange.