Run Bitwarden behind reverse proxy

Hello:) I have a problem after running Bitwarden behind a reverse proxy. The installation of Bitwarden was normal and ran without problems before the change. If more information is needed, I will provide it.

What is the problem?

Error 1:
Now when I call git.mydomain.xx I am redirected to the url ‘https://bit.mydomain.xx/#/’ where the login also appears. Now when I reload the page (F5 or reload), I get a timeout. Only if I enter the domain again, it works.

Error 2:
Since then the sync between my clients does not work. Syncing failed

What did I change?
bwdata->docker->docker-compose.yml
ports:

  • ‘800:8080’
  • ‘445:8443’
    After that the command ‘docker-compose up -d’ was executed and ran without error

installed nginx and created the following config with www-data:www-data owner:

server {
   listen 80;
   server_name bit.mydomain.xx;
   return 301 https://$server_name$request_uri;
}
server {
    server_name bit.mydomain.xx;
    listen 443 ssl http2;
    ssl_certificate /etc/letsencrypt/live/bit.mydomain.xx/fullchain.pem;
    ssl_certificate_key /etc/letsencrypt/live/bit.mydomain.xx/privkey.pem;
    ssl_protocols TLSv1.2;
    ssl_prefer_server_ciphers on;
    ssl_session_cache shared:SSL:10m;
    ssl_session_timeout 10m;
    ssl_ecdh_curve secp521r1;

    client_max_body_size 10000M;
    access_log                  /var/log/nginx/access.log;
    error_log                   /var/log/nginx/error.log;

    location / {
        proxy_set_header        Host $host;
        proxy_set_header        X-Real-IP $remote_addr;
        proxy_set_header        X-Forwarded-For $proxy_add_x_forwarded_for;
        proxy_set_header        X-Forwarded-Proto $scheme;
        proxy_pass              http://127.0.0.1:800;
        proxy_read_timeout      90;
        proxy_redirect          http://127.0.0.1:800 http://bit.mydomain.xx;
    }
}

What have I tried?
Looked at the error log of nginx, but no entries.
rebooted server/services

more I do not know what to look for