Problem with websocket-based live sync

Hey guys,
I just set up my self-hosted bitwarden instance with a family license. I then came to notice that the Websocket connection didn’t work on my on-premise installation so I digged a bit and figured it out to the point the websocket is successfully opened (http 101, I had a problem before with the reverse proxying but that’s fixed now). Problem is: although the websocket is open the live syning doesn’t work at all. Neither between browsers nor browser and desktop client.

Out of curiosity if it could possible not be my installation I tried the officially hosted vault but it didn’t seem to work there too.
Can anyone confirm? Is there an explanation? I tried with several browsers.



I’m having the exact same problem.
I’m using the official self hosted docker solution and websockets are working however live syncing is not working anymore. Push to mobile devices likewise doesn’t happen.

Just as you did i then tested with my account on the official bitwarden servers with the exact same result, however i didnt test the mobile applications with the official servers.

1 Like

I’m having this problem too.
I am also selfhosting the offical docker version. And I also tested the live sync feature on an account on the official servers. Never could it get working.

Are there any news about this issue?

same probleme here.
There is no sync between devices.

Testet : Webbrowser, Win Client, iOS APP , Android APP and Chrome Addon

1 Like

I created a new account (no self host) and logged in to some devices (browser, windows client and android smartphone) … without differences.

Whats wrong ?

1 Like

Hey, tech-ducks.

What do you mean by “without differences”?

I mean that there are also the same problems then self hosting.

For me the “live sync” function does not work in self hosting and bitwardens vault.

So i am always nees to manually sync the vaults

1 Like

See here:

Thank you for the hint @Peter_H.

I will report whether the support could help me or not.

1 Like

For me the issue is resolved. The support couldn’t help me, but after the last few updates everything works fine.