Problem when enrolling my FIDO2 key

Hello everyone.

I’m trying to enroll my FIDO2 key for webauth login. I can fill name and read key but when I click on save, I got this error An unhandled server error has occurred.

I have bought premium licence, and I’m on a self-hosted installation. I followed the official install guide. My bitwarden is behind a nginx reverse proxy.

Does anybody have a solution ?

Thank you for you help and have a nice day.

Hello @RN232 and welcome to the community,

Awesome to hear you decided to purchase a premium license, it’s always a great feature to get the ability to self-host your own services too. Glad to hear you are taking advantage of this feature.

I know self-hosting can be a good learning experience, and once up and running a great accomplishment though as someone who does it for a living, there are some things I don’t mind to maintain and those I’d rather just leave to others :rofl:

That being said if you are running a good self-hosted solution with solid backups, security patches, and minimum public accessibility, etc. then feel free to go at it.

Do you know how your initial Bitwarden install was setup behind your Nginx reverse proxy? As I believe Bitwarden also spins up its own proxy solution in the stack, but I believe there are some environment variables you can put into the environment override file to alter the Bitwarden Nginx listening ports for your own reverse proxy solution in front.
I assume since you are able to get to the Webvault and add your license, etc. that this was set up and your reverse proxy talks to and forwards traffic to the Bitwarden stack at least and is accessible.

There is also the manual install process, which is a bit more involved and for advanced admins, but may help to fit your use case possibly.

Hello @cksapp.

Thank you for your reply. Yes I am quite a friend of the self-hosted, I like to keep everything within my reach.

I took a look at the manual installation, maybe the problem is the double reverse proxy that doesn’t redirect some pages as it should. I’ll look into it and get back to you with a possible solution.

The manual install may give you more flexibility but as mentioned does have a bit more nuance to it.
With your current setup you may try to check out these posts in the community, as it may help.

EDIT: Checking further this may be something that is specific to the FIDO2 auth, as others have had a similar problem.

So hopefully double checking the settings can help, otherwise perhaps the manual install may be needed for your own nginx reverse proxy and webauthn to function.

Wow that was so long ago.

I have now updated my old thread with my solution (basically install Bitwarden fresh and choose not to use LetsEncrypt and only expose it to localhost, then set it up in nginx.

Hi @dinosm,
Glad your solution worked for you. In my case, there was an inconsistency in my configuration file. I did as you did, not generate an SSL certificate and let my existing Nginx handle it. The local bitwarden is in HTTP.
Except that you have to be careful in the variables file to put “” and not “”. That solved my problem.


Didn’t realize you may get a ping simply from simply linking the post and not tagging anything so my apologies if that was the case.
Thanks for the update though! Hopefully it can go to help any others who come across these threads :slight_smile:

@RN232 very glad to hear you were able to double check your settings and found a misconfiguration which once corrected has fixed the problem and let’s things work as expected.

Nothing to apologise for, it helped get me to update that thread to help others who may come across it :slightly_smiling_face: